Xiaomi Mi Roborock S50 vacuum cleaner token

Anyone who have managed to get the token out of their Roborock S50 for use in the Xiaomi Mi Home app?

I have deleted my vacuum from my Mi Home app on my phone, and reset the WiFi settings on the vacuum. I then retrived the token by the Packetsender tool, added the vaccum to my Mi Homa account again, but the token is not accepted when I try to add the vaccum to my Homey.

Any suggestions?

1 Like

Follow any of the intstructions here by the letter: https://github.com/jghaanstra/com.xiaomi-miio/blob/master/docs/obtain_token.md

You should not add the device to the Mi Home app after retrieving the token. It will reset once added to the Mi Home app. You should retrieve it after you have added it to the Mi Home app using the described methods.

So the robot should first be set up in the Mi Home, then reset WiFi and retrieve token, and then connect the robot to WiFi again? Will try when I am back home again.

Do not reset the WiFi after adding the robot to the Mi Home app. Just follow the instructions in the link I posted.

Ok, this is where I am lost.
The instructions tells me to start with a reset of the device WiFi. I connect to the device with my computer and retrieve the token and save log. I complete the setup in the app by choosing the same WiFi as before, and retrieves the token again before it connects to my wifi. All tokens retrieved is the same.
After the robot is connected to WiFi I tries to add it to Homey. After adding IP and Token whith or without spaces between characters, I always get a “Could not connect to device, token might be wrong” message.

BTW: I can start, pause and dock the robot from my Google Home. That integration did not require a Token…

Follow this guide for a simplier way to get the token



@jolerius thx for sharing the link. Had my roborock s50 connected to homey in 5 min.

It took me a lot more than 5 minutes to follow the procedures (Each re-flash takes more than 5 minutes…), but still the same end result: Could not connect to device, token might be wrong

@MbenzNo download the modified mihome app.in jolerius link. Remove the mihome app on your phone… install the modified app. When finished go to network settings in the mihome app. There you can vind ip and token.

Finally worked! The issue was probably an issue with my WiFi router that for some reason rebooted WiFi every 1,5 minute. This is now fixed and the Robot installed in Homey without a problem.

1 Like

Is this a good robot vacuum cleaner?
people advise me constantly Roomba or Neato, but I haven’t heard anything about Roborock

1 Like

I have replaced my Neato Connected with a Roborock s50. Could not have been happier! Roborock cleans as good as Neato, but is quicker and smarter than Neato.

Mbenzno. Just wondering how you find the Roborock as a cleaner? Did you look at many other brands before you chose this one and if so what made you go for this one in the end? Thanks for your reply in advance.

As i said in my last reply: I replaced a Neato Botvac Connected that in most tests is among the best robot vacuums you can buy, with a Roborock S50.

The Roborock cleans as good as Neato (That is very good). The Roborock is quieter, automatically detects carpets and increases suctions, it is smarter in figureing out obstracles, it is quicker, and have a better app.

And last: The Roborock is substansial cheaper to buy compared to other “High end” robot Vaccum cleaners. What’s not to like?

That’s great. Thanks for your response.

I use Roomba and solved such a problem with reinstalling the application.

Thx jolerius! Awesome app, I got the token in no time at all. =)

The link cannot be opened. is it a guide or apk file?

Its a google drive link. Maybe u have to have a google account