Re-initialize app

Is it possible to re-initialize an app without restarting it? If so, is it possible to do without a flow?


Well, without a flow it would have to be manual. But what is your problem, or what do you want to avoid that is negative of a flow or an app restart? It sounds to me like you’re asking how you can jump in a pool without getting wet and without moving your feet.

1 Like

Iis this a developers question? There is a category on the community for that.

I mainly wanted to save time, if reinitializing it was faster than restarting the app. The problem is my qubino switches. They stop responding from time to time, and the “fix” is to first disconnect them (the fuse, usually), connect them again and then restart the app. That works most of the time. Some of the time an app restart does the trick. So I just need something quick to go through the steps when it stops working. Now, it’s just easier to disconnect it, wait 5 seconds, connect it and then restart the whole homey - and in 99% of the cases it will start working again.

Well, rather than optimize the workaround, Id rather try to find out why they drop out in the first place. Can you share a screenshot from the developer page of you z-wave mesh and point out which ones are misbehaving?

By the sound of it they are built in a wall? Do you have other mains powered z-wave devices, and are they always connected to the mains or are they disconnected from the mains at any time? E.g. if you have smart z-wave bulbs and some-one accidentally turns off the power to them, your qubino’s might lose their route to Homey.

1 Like

Thanks, but none of the other z-wave devices in the same area have problems - and the main culprit is actually between the other z-wave devices in the “sector” and Homey. I’ve had similar problems with my other qubino switches, and I’ve replaced most of them. The one I’m having the most problems with is used as a scene controller (three inputs, one output) and there’s nothing that should interfere with it. None of the other devices on the same circuit are acting up, except for the other qubino of the same type used as a remote for some lights on another circuit (WHY would the people who built the apartment make a light in the bathroom with a switch in the bedroom - when you have to walk through the whole apt to get to the bathroom? :astonished:)

  • From the developer page I see none of the other devices are using this as a router, which is strange.
  • The qubino is using a direct route (4-5m from Homey)
  • It’s always connected - the fuse is the only way to turn it off

Are the Qubino’s added as secure? In that case I would highly recommend including them non-secure by removing them and adding them again as a Fibaro Walli (they will still be added as what they actually are, just not secure).

Thanks, I will try this :slight_smile:

1 Like

Ok, so that was messy. I had to disconnect the switch in order for it to go into include mode - and since the fibaro app required two of these I had to…do it twice. Took me a while to figure out how to get it into include mode without restarting the homey :wink:

But…after adding it as a walli switch it’s still connected as secure. Are there other ways to do this?

Excluding and Including has to be done very close to Homey ( or bring Homey close to the device)

Huh? That is a first for me, I just included 5 fibaro dimmer 2, an aeotec wallmote and a Robbshop remote the same way, all added as insecure (and if done the usual way: secure - I tried). No, unless the manual states another method, I do not know any other way and this always worked.
Qubino’s I did in the past.

1 Like

I was within 1,5m - the closest I could get while on a different circuit. I tried on the same circuit, but the qubino just wouldn’t enter include mode without breaking the fuse. (I could have disconnected it from the mains, but…I would then have to work on a live wire, and I prefer not to :wink: )

I’ve sent a request to qubino asking if the device does not support non-secure inclusion. I might try again later tonight, but adding it as wallie didn’t work the first time…Not too sure if removing and re-adding it will do a whole lot, but I’m up for trying.

I guess I’ll have to replace the whole switch as soon as possible. It now seems completely dead. I got it removed from Homey, but now it doesn’t feel like going into association mode. Again. Hopefully, the whole non-secure problem is because of a defective switch.