Qubino RGBW dimmer

I have several 24VDC monochrome ledstrips connected to Qubino RGBW dimmers that are controlled by Homey. The momentary switch input is on IN1 and that is set to brightness mode. The ledstrip GND is connected to the “white” output. I think that is Q4 ( as says the manual) but I am not sure…

The ledstrips are sometimes behaving strangely. They extinguish all of a sudden and when I look in the app, I see that the color has changed. Fiddling around with the color turns on the ledstrip again. Also, sometimes changing the dim value in the app turns it on again. And at other occasions the ledstrip does not react at all on the physical switch.

Unfortunately no real pattern here…
Does anyone experience similar problems with the Qubino RGBW switch? Maybe we can find a pattern and solve this?
I am not sure even if it is the Homey Qubino app or the switch itself. One thing I noticed, is that RGBW switches which were not yet included in the Homey network did not show this behavior. Only after being included it started.

Some additional info:

On advice of Qubino support I tried to set the RGBW dimmer to 4 dimmer mode. A complication is that parameter 14 needs to be set, and that cannot be done directly through Homey. It needs to be done by setting raw parameters. So that is what I did.

I have tried this in the past and failed, but thought well, let’s try it again. Alas, it didn’t work. When I want to switch on the dimmer in Homey it gives an error message “cannot read property ‘SWITCH_COLOR_SET’ of undefined”.

By-the-way, the RGBW dimmer can be switched on and off by using the 3-dot menu on the developer website.

I guess, first you should make sure that your connections are as they should be,

Don’t see a GND on the LEDstrip in the picture, but there is a DC+ , so the R,G.B,W wires are pulled-down by the dimmer.

If your LED-strip has only 2 wires, V+ and GND, then V+ must be connected to + voltage on the power supply and the GND from the LED_stip connected to the “White” connection of the dimmer.

It is very important to have a very stable power supply, maybe an extra capacitor could help.

It is connected like you say, otherwise the LED wouldn’t even illuminate I think :upside_down_face:
The issue here is un-commanded color changes (which can be seen in the app) resulting in the (monochrome) ledstrip switching off.
Is this a Qubino issue or a Homey issue? The latter wouldn’t surprise me alas, given all the other problems I have in my z-wave network and the general instability of Homey :sleepy:

Is this a Qubino issue or a Homey issue?

was the question in my last post. I think I have the answer.
I excluded a Qubino RGBW switch from Homey, set up openHAB on a Raspberry Pi3 added the switch.
And what do you think? Same behavior! So, this looks like a Qubino issue.
Next… finding a solution. I already contacted Qubino support for this in the past and have just updated them.

Will let you know what they say…

Are you sure it’s not your power supply giving the trouble?

Good question… I have a Meanwell 350W transformer on a 150W ledstrip. So, should be OK. Also my other transformers are equally oversized. But they are all Meanwell… I could try another brand, of course.
Currently I have excluded a RGBW switch and reset it to factory settings. It is on now for about half an hour, so the test continues :wink:

I also just found an interesting thread on how to set the RGBW switch to 4 dimmer mode in Homey (or any other controller using raw data) : http://forum.micasaverde.com/index.php?topic=123955.0
Careful!! This is for a Fibaro RGBW switch and not a Qubino. But it could also be an avenue to walk. I previously used other raw commands to set the Qubino to 4 dimmer mode, but maybe I should set all four channels?

Guess you already found this page?

and specially:
NOTE: After parameter change, first exclude device (without setting parameters to default value) and then re include the device.

Yes I have, and I excluded and included again.
After inclusion the dimmer did not work anymore and therefore I am not sure if the raw command I used worked correctly. I noticed however, when I included the same dimmer in openHAB, that parameter 14 was set correctly. I am going to factory reset the dimmer and then go the other way: set parameter 14 with openHAB (which can be done in the UI) then exclude and include again in Homey. See what happens.

There was another thing that puzzled me when I read the document you are referring to, is an ambiguity when it comes to the max Amps per channel:

8A for single output channel,13A at max.(3,25A for R.G.B.W. single output channel is suggested)

My larger ledstrips are 150W, so around 6A, good enough to comply with the first part of the sentence, but what about the las part mentioning 3,25A? This is a question for Qubino support.

1 Like

@josjg Did you get the Qubino RGBW dimmer to work with Homey in 4 dimmers mode?
I managed to configure my Qubino RGBW dimmer in 4 dimmers mode (by setting parameter 14 to 1 (“14,1,1” in raw parameter configuration) and then re-included it). However after re-inclusion Homey still treats the dimmer as RGBW instead of 4 dimmers. The UI is showing color switches and I’m getting errors: “Cannot read property “SWITCH_COLOR_SET” of undefined”.
FYI I’ve just switched to Homey from Telldus ZNet lite v2. In the Telldus controller I had the Qubino dimmer working fine in 4 dimmers mode. :anguished:

@ajoj No, I didn’t. I was able to set it to 4 dimmer mode (I used Home Assistant for that) but it doesn’t show up as 4 dimmers in the UI indeed. I got the same message about the color property as you did. I just bought Home Center 3 because I am fed up with the poor performance that Homey gives when it come to z-wave, so maybe I can let you know how it work with HC3 later.

There seems to be another issue however with the Qubino RGBW switches. In my home they switch off uncommanded at irregular intervals. Sometimes I notice that the dim level is set to 0% and at other times the color has changed. I have my Led strips connected to the White output, so, that might be the reason that they switch off…
When I disconnect the physical switches from the RGBW switch the problem disappears! And I can control the led strip via Homey.

I thought, at least until a while ago, that that was due to the fact that I had 24VDC wires running close to 230VAC, but that isn’t the case for all RGBW dimmers I have. And all of them have the same problem, even the ones that don’t have the DC and AC wires close together. But still I think it is some sort of interference problem. I am discussing this with Qubino support.
I have replaced one of my Qubino dimmers with a Fibaro RGBW Controller 2, and that works just fine. Except that Homey doesn’t support it :smirk:

@josjg Ok, good to know that it is not only on my side!
I actually had similar issues with my Qubino RGBW dimmer in 4 dimmers mode that it switched off randomly (when connected to ZNet lite controller). Now I have to run it in normal mode together with Homey. Actually, I’m also only using one of the channels (W) but want to run it in 4 dimmers mode to be able to use the extra inputs as triggers for different scens/flows. With Homey I apparently need to add another device for that :anguished:
BTW. I’ll let you know if I have issues with random switch off together with Homey in normal mode as well. So far I’m not really impressed by Homey, but HC3 is not an option for me since I have a lot of 433MHz devices as well.

I have switched to HC3 in the meantime. Easy and reliable z-wave inclusion, no lost devices (so far) and answers from support within 24 hours!
HC3 is still in development and indeed no support for 433Mhz (yet) Documentation for LUA and QuickApps could be a bit better as well, but with help from the community I have been abel to solve everything for now.

I haven´t really been able to judge how the RGBW switches work with HC3, but I still have a feeling that the problems I have with these switches stem from som sort of interference. The Qubino RGBW switches are apparently very sensitive to interference in the wires leading to the inputs. I wonder how your experience is with that?

In the meantime I have bought a couple of Fibaro RGBW Controller 2. These don’t have any interference problems and work fine with my monochrome ledstrips.

The drawback is that the Fibaro controllers have a limit of 12A and 6A per channel. That will suffice mostly, but I have two strips that draw a bit more. I associated a S input on the Fibaro RGBW controllers with the Qubino RGBW switches powering the more hungry lesdtrips and connected the wires of the physical switches S inputs of the Fibaro controller. (In my case endpoint 4 for both groups 2 and 3)
Works like a charm!

1 Like