Problems: Popp 004001 - Smoke Detector and Siren

Hi all,

I have two popp smoke sensors for a while now. I never thought about testing them, but due to updating to 2.0 and finding compatibility for all the apps I realized that my smoke sensors have never worked.

  1. The alarm isn’t going off:
  2. I’m unable to use the sound as a flow card:
  3. This one is really minor: one is showing battery, while the other isn’t.

I think @MarcoRuiter is quite busy, because all the apps he makes and I can see that the app hasn’t been updated for a while (also the beta version which I am running). Since I find this part of my domotica very important I was wondering if anyone in here with programming skills maybe find the above problems, so we can make a pull request.

Thanks in advance!

oh, i will test my alarm flow tomorrow with my popp smoke detector with siren.
i will tell you then my results

I had the same and therefore returned it. I also emailed Popp, they told me they had no intention of testing and/or supporting homey.

Maybe off topic: I also have a popp outdoor solar siren. In flows it does respond to ‘turn on’, but never to ‘change state to alarm’. In addition I figured out that I needed to put a small time delay between different sirens to get reliable results.
Btw: The option ‘turn on’ was never present in flows before homey2.0. Maybe this could give you another possibility to get yours to work.

Thanks for your response. I don’t think it’s has something to do with Popp itself, since Z-wave is an open standard?

I guess you’re right. I was mainly checking if popp had tested their stuff on homey. Apparently not. Which surprises me, they should be interested?!

@PhilS, I’m really curious to your results. Which version Homey and Popp are you running?

Just tested today my Popp smoke sensor with integrated Sirene. It works if I switch it on and off with the app. So I think my alarm flow will also work.

I am on firmware 2.0.0 and have the new homey app gen 2.

Popp app version 1.1.7

Turning on and off the sirene is working here also. Is totally different with the alarm which should be generated in case of a fire.

Ok, then I will Test it with the alarm Flow tomorrow.

I reported these issues on github last summer, and can confirm that they are all still present. There has not been any development.

Hmmm, just tested my alarm flow and the Popp siren worked. Also the deactivate flow with silence the alarm worked.

Firmware 2.0.1-rc.2

Hi PhilS,
If you are using the popp app version 1.1.7 you can trigger the siren on and off using flows, and that works. (If you are using the latest beta, you can not as you will have a card not registered error as described here:

The problem is that no flows are triggered when smoke is detected (by using test button or actual smoke). Even though the smoke detectors all emit sound, that is because they are linked, but not through homey. You can try by sending a push message to your phone at the end of the flow that is supposed to start when smoke is detected… No message will arrive. So if you are not at your house, you will not hear the smoke alarm, and you will receive no notice.

Oh. Okay, but only in the beta app?
That‘s Strange and not good. I understand

I have the 1.1.7

Seems to be the problem in both

Yes, both the beta app and the stable app has the issue with flows not beeing triggered when smoke is detected.

Any programmers in here who know where to find this problem in the code (about not generating alarms when there is smoke?). I have been looking into it, but since I’m not a programmer I have no clue at all where to search / look at.

I find it important to be fixed, since it’s such an important thing in my house.
@MarcoRuiter are you still maintaining this app?

No notification for smoke alarm. Anyone interesting in to have a look at the code?

1 Like

I have been looking into this, but unfortunately I’m unable to test. Regarding to this URL somebody contacted POPP and they confirmed that the test button does NOT trigger the smoke alarm.

Regarding to this topic some people experience problems when with index 3. The documentation state that the default value is 99, but they experience it will work with 255 instead of 99. I tried to change this under the device->advanced settings, but then I get an error thrown: “failed_to_set_3_to_255_size_1”. So this also doesn’t work (value basic on command). Therefor if we want to change this value, we have to change the app to test.

So I looked into the github to change this value:

app.json: rule 292
config / apps / 004001.json: rule 110

Furthermore I notices the following:

app.json: rule 3307, I should expect here “filter”: “driver_id=004001” instead of the 005107


I’m having the same issues. The 10 year smoke detector works fine, but no flow is triggered when the alarm is activated. I have a can of test smoke, which triggers the alarm. But Homey doesn’t do or show anything. No smoke alarm is detected, nor does it show a sabotage alarm. Any suggestions cause the Homey integration has no added value like this.

Homey and the detector do communicate since I can turn off and on the siren.

By the way: I also have the CO detector, and this one has a working sabotage alarm within Homey, but for temperature and CO no values are shown.

@MarcoRuiter is the app still maintained?


I have recently bought 4 Popp 10 year smoke detectors (POP_E009402). I cannot test the smoke alarm (I have no test smoke), but the sabotage alarm also is not activated when I take the detector off the wall mount. Activating the siren works.

I also bought a CO detector (POP_CO_detector_004407) but it is not yet delivered. I noticed that the name of the CO detector is not correct. In the app the name is CO2 detector instead of CO detector.

As soon as it is delivered and connected, I will file these issues in his github: Hopefully he will find some time to solve the smoke detector issues and rename the CO2 into CO.