Problem with the Mi Flora app - not connecting

I bought this “VegTrug Flora Care” via Aliexpress. I download this app:

First what I did was download the Vegtrug app and connected it with + updated the latest firmware. Then I removed the connecting via BT, so no info was found. Then I pull out the battery and reinserted it again for a new BT connection. On the Vegtrug app it will found it, but I didn’t continu with it. On the homey it won’t find it whatsoever. Tried it many times but still no luck. Is this the right chip or device for that?

I got a Mi Flora stick also BT, pairing works only if it is literal next to the homey. After pairing it can be moved around a bit , but the range is terrible.

You could possibly work around the range issues with Homey by using an ESP32 using the BLE tracker component and let it publish to MQTT (so you can pick it up with the MQTT Client app). ESP32’s should be able to handle the normal BLE range of about 10 meters.

Everything seems to be working now! :slight_smile:

That sounds great but pretty complex. Isn’t it hard to get it done? :thinking:

ESPHome is reasonably easy to understand :slight_smile:

Yeah, well… after taking a look at the homepage I need to confess: It’s way to complex for an average Joe as I am. :grin::man_shrugging:

Isn’t there a possibility to easily build kind of a Bluetooth mesh that covers a house? :thinking:
I just read the loooong antenna mod thread but this is very difficult and lots of things to be done as well :man_shrugging:

I have the same problem that you had. How did you solve it?

Few times re-connect it, and then I had luck that it appear in homey.