Problem Sunricher z-wave dimmers


I’ve got an problem with my Sunricher dimmers (SR-ZV9040A_Micro_Smart_Dimmer).

Intermittently they just stop working. The problem that occurs is that I cannot controll them via Homey anymore and also the physical switch on the wall stops working (momentary switch) I got this problem with several of my dimmers.

The faulty device reports unknown and unreachable on the developer site.

Troubleshooting done:

  • Tried to heal all my z-wave devices, just not the one that got the problem.
  • Rebooted Homey
  • Can’t remove the device from settings.
  • Removed it from the developer site, but can’t add it again
  • all the other Z-wave devices works fine at the time.
  • Tries to press the switch on the wall 3 times fast. Also tried to hold it down for more than 10 seconds to see if it resets.

The only thing that fixes it (what I know) is if I open up the wall socket and just press once on reset on the dimmer, then it starts working again. Both in Homey and the switch. So I do not need to remove it or anything before doing that.

Tried to find info regarding this, but couldn’t.

Any suggestions?


be sure to follow all the steps in this link, if it doesn’t help, probably your device is broken.

I don’t got any problems to add the devices, it’s that they stop working randomly with the described problems.

Also think it’s a bit unlikely that 3 dimmers should be broken :confused:

If they aren’t included the right way (fi. to far away from Homey), you can get all kind of strange behavior, jus mentioning it, I have no other idea, succes.

Hi Johan. Did you manage to solve the problem? I’m experiencing the very same. I recently installed 8 Namron dimmers which are the same as Sunricher, just branded different here in Norway. In the past two days, 3 of the dimmers have stopped working at randomly, leaving lights on or off depending on state before they failed. Turning off the power to these (through the circuit breakers), will bring them back to life again (quicker than disassembling the switch to press the reset button).

As it is, the behavior of these dimmers makes them useless, so I hope there is a solution to this.

Best regards Eirik

I have the exact same issue. Did you guys figure it out?
Best regards