Plugwise Source App


Homey app to integrate Plugwise Windows desktop Source in Homey.

Works with data retreived from Plugwise Source Server . Controls Circles and Stealths with Homey.

30-08-2016 version 0.1.2 first app store release changes : only Circles and Circles+ can be added as Homey socket devices.

There is a special Homey app for the Plugwise Smile P1 in the Athom App Store so it isnt included anymore in this app.

Bug fixed : Testing Plugwise Source server doesnt give crash app anymore.


21-11-2016 v 0.1.40 removed bug compatability >= 1.0.39

21-11-2016 v 0.1.39 added node module node-homey-log to map node_modules

18-12-2016 v 0.1.38 version homey FW lifted to >= 1.0.3 removed bug when switch a socket app crashed. added Sentry log require, not implemented yet

18-12-2016 v 0.1.28 moved the initialization of the app settings values to app init from the global space to prevent app crash after reboot or update homey

15-10-2016 v 0.1.18 firmmware update homey to 0.10.5 did give problems with saving settings of server, is solved by bvdbos.

25-09-2016 v 0.1.7 deleteted line 30 in driver which gave app crash in Homey firmware 0.10.0

01-07-2018 v 2.0.0 SDK 2 version setting locked included to lock circle, and circle can be added as Homey light

03-07-2018 v 2.0.1 SDK 2 version node modules were excluded in gitignore, light virtual class didnt work , now it works

08-08-2018 v 2.0.2 fixed a bug

14-08-2018 v 2.0.3 added stealth as a circel device

03-02-2019 v 2.0.5 removed bugs that caused immedate crash in V2, the drivers loaded to slow in v2 so some objects werent ready in the app.js

02-08-2020 doesnt work in Homey V5


I planned to add my circle+ but Homey doesn’t find it.
I tried several apps
Do I need more then just a circle?

my plugwise app communicates with the plugwise source server installed on a computer. For my plugwise app you need a plugwise stick to put in a windows computer. If youy have a plugwise stretch , then athom has self made an app for it.

So yes you need more then a circle+

1 windows computer with plygwise source server installed on it and a plugwise usb stick inserted in the compter


2 plugwise stretch


a plugwise stick in a raspberry pi and install some programs

1 Like

I have Plugwise source installed on a windows machine.
The circles are online, but when i choose the option in Homey it cannot be found.

What to do ?

in the plugwise source program on windows computer the plugwise webeservewebserver must be running .

check that in the plugwise program see picture and in the homey plugwise settings you must use the correct ip ,port and login credentials

you can check from another windows computer if plugwise webserver runs with http ://hostplugwise:port

Is it possible on the Anna app to see in a flow it the CV is burning so I can switch some pumps.

i didnt write the ana app . and dont have an anna, contact the writer of the ana app

the ana can be reached via the plugwise stretch app , the source has no connection with ana. so no ana in my app where did al the replies went i got in my email box ?

I upgraded to 2.0 and now Plugwise app chrshes all the time.
When looking in the settigns is says UNDEFINED on all fields.
But after writning all my ip-adresses and ports etc
It crashes again.
I have over 20 Plugwise cirlcles so HELP PLEASE !!

i know plugwise isnt working for some reason in v.2.0.0 i cant figure out why. the app settingspage is changed to v2 , but a lot more is changed in the app api i am not aware aof. so i dont know if the plugwise app wil ever work on v.2.0.0. i didnt know as developer they would make is stabel so soon. in my opinion it isnt yet , but thats my humble opinion. all my apps dont work in v. and plugwise is at the bottom of the list to do. there are a few more important apps which should be fixed before plugwise

Hmm, app seems to work in 2.0 for me atleast. I get power consumption in insights atleast.

On the other hand, I don’t use on/off on a single plugwise I only use it to record power consumption.

There are like 5 Plugwise apps so I’m guessing that you’re using a different app than @Kalle_Kronbeck.

I reinstalled the app and now evertthing works

Don’t expect much from Plugwise, or Anna support. I have plugwise devices… In my experience they only want to sell. Development i.e. native Plugwise support, no reaction. I’m also looking for a thermostat but Plugwise, NO WAY! Athom now offering for 99… be wise, no Plugwise.

Plugwise has different systems. I have the stretch with the (old) plugs, really working perfectly with Homey. Don’t know if the new plugs (Zigbee) are already supported. Source, with the old plugs, was really cool but you need a windows-computer to work with that iirc. Pity is with the Stretch you are no longer able to program plugs. But hardly needed anymore since we have Homey.

My first reply by email

Verzonden vanuit
voor Windows 10

Seems like after a reboot the plugwise app looses all it settings wich causes the app to crash.

there is a fix pending approval athom , submitted the app 2 days ago you can install the app via github and cli or wait .