Philips Hue picking colors not working in iOS Home-app

Hi guys,

I’ve been using Homey for a while now, but I was still using my Hue-bridge to get lights in my Homekit-app on iOS. This resulted in double lights, which was quite annoying, so today, I removed the Hue-bridge from my Homekit-app.

All lights are there, but I have trouble picking colors. Both when creating scenes, but also when picking “live”. See the below video:

As you can see, I try to pick a color, but it jumps back to temperature (I’m not doing that) and the color doesn’t change. Has anyone noticed this as well? If yes, are there any fixes out there for this problem?

I’m also noticing that not all lights turn on or off when selecting a scene (I did not have this problem when connected to the Hue-bridge), which means I sometimes have to run the same scene twice, but I have a feeling I have read somewhere that this was Homey’s fault and should hopefully be fixed in an upcoming software update?


I have done some testing, tried with the Homekit-app (had Homeykit before) but the problem persisted.

I can change the color through the Homey-app on my iPhone without trouble, I can change the color through the Hue-app, but I CAN’T change the color when trying it through the Home-app on my iOS device.
I have tried on multiple iOS-devices and it has the same result: the light I’m trying to change the color of, changes to a white temperature (often cold white, can’t find out why).

Just knowing that anyone out there has the same problem would already ease my mind, but a solution would be even better! :smiley:

Finally solved it. I added my Hue-bridge to Home again, and turned all the lights and such, that are connected through the Hue-bridge, “off” in Homeykit, so I don’t have double lights anymore. Also, I can finally create a nice Christmas atmosphere now :smiley:

Apparently, changing color through Homey is not supported.

Hello @Robbert.
I have/had this problem as well. I just fell back on using the Hue bridge as you ended up with. Never reported it (guess I should have, but not my biggest issue in my setup).
Would have been nice to get it all working in Homey directly.
I also ended up adding my IKEA lights trough the Hue bridge, so I kind of need it anyway. Since I had issues when trying to add IKEA lights and controlling then with the remote at the same time.
Unfortunately, now I cannot get one IKEA RGBW bulb to switch to colors anymore. Just shades of white. :roll_eyes:

Yea, I think this problem is more widespread than people think, but it’s just not noticed, because they add their bridge and bulbs correctly from the start (instead of all through Homey, they use the Hue-bridge for hue-bulbs and products).

I am going to file a report, because this seems to be a bug somewhere in Homey, not being able to interpret color-commands.


Anyone having any luck with controlling IKEA RGB lights trough the Hue hub?