Onkyo receiver 2.0.2 update not working

Hi guys,

Couldn’t find a previous topic on Onkyo receivers (probably because the device/app was working perfectly! Until yesterday, unfortunately…

Update 2.0.2 is not working for my Onkyo receiver. Homey still connects to the device, but can’t process any requests in Flows. For some requests, an error occurs (red cross, e.g. volume up/down) and others keep loading. Any way to downgrade to 2.0.1 ? In the past, I was able to find earlier packages which I could install manually, but I can’t seem to find previous packages (on Github). Help? :frowning:

Can you run it in the developer mode and execute 1 flow action that doesn’t work, and let me know the output? I have tried most of the flows but 2.0.0 was a really big update, so I have no doubt there can be some more errors in my code…

2.0.1 is at this point by the way:

Really stupid question: how can I run it in developer mode? Is that a setting in Homeys config on the desktop app?

Not a stupid question at all, it’s quite hard to explain. But since you mentioned that you install packages on Homey through Github, I think you are already doing this…

Instead of athom app install, you do athom app run

This will make it possible for you to see the log output of the app.

I’ll try it at home soon.
In the meantime, the entire app crashed yesterday when I tried to start a flow!

Are you on a really old version of Homey? (I saw a crash report yesterday with a 1.0.3 Homey version)

1.0.4., yes. Should I upgrade? :wink:
Crash was when I came home yesterday, 14h ago according to the app

edit: Homey is on 1.5.11, the desktop app on 1.0.4

Desktop app as in Homey desktop app?
Kill it and use Chrome browser!

Desktop app works just fine, and Chrome, Firefox and Safari all report that browsers are not supported. I’m on Mac, maybe that’s different?

I managed to navigate to the app folder on my Mac, run the app in developer mode, but the app keeps running in Terminal with quite the same lines of code as output. What am I doing wrong?

That’s exactly what you need. Now just perform the action that crashes the app, and give me the last few lines that appear when it crashes

Okay, here it is.
Device: Onkyo TX-NR636
Flow 'Spotify Plays: If button X is pressed; then:

  • Turn on : receiver
  • Turn off: TV
  • Change volume: 18
  • Change to input: NET

Output in Terminal:

Onkyo receiver app - sending !1PWR01 to
[CBLOG] 1PWR = function (result) {

			if (result == '1PWR01') callback (null, true); else callback (null, false);

args = {“input”:{“icon”:"",“name”:“Net”,“inputName”:"!1SLI2B"},“device”:{“domain”:null,"_events":{},"_eventsCount":9}}
}, args.input.id.substring(1,5));

TypeError: Cannot read property ‘substring’ of undefined
at Homey.Device.changeInput.register.registerRunListener (/drivers/receiver/device.js:931:21)
at FlowCardAction._onRun (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/FlowCard.js:1:1246)
at emitThree (events.js:136:13)
at FlowCardAction.emit (events.js:217:7)
at ManagerFlow._onRun (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/manager/flow.js:1:2274)
at _eventListeners.filter.forEach.t (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/HomeyClient.js:1:1219)
at Array.forEach ()
at HomeyClient._onMessage (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/HomeyClient.js:1:1196)
at emitTwo (events.js:126:13)
at process.emit (events.js:214:7)

— INFO: com.onkyo has been killed —

Is it possible for you to play spotify start from a flow?

No, not yet. The flow is just named that way. But looking forward to it with Homey’s update!

Can you try to recreate the flow that does the input change? Just delete the action card on the “Change input” and redrag it from the device into the “then” column.

The fieldnames of the inputs are changed so Homey now passes “wrong” information, while the app itself is correct. I didn’t think of that in time (or actually I didn’t expect this to happen), sorry.

Yes, that works! I noticed it, now. Some inputs were all caps, which have lower case characters now.
Thank you! So now the Onkyo app is developer-installed on Homey; should I change back to the ‘regular’ version? Can I do that without losing my flow/device preferences and data?

Problem has returned… quite annoying. This time, I tried re-connecting the receiver altogether, but still nothing. I did re-install the app from the Homey App Store. Can you help me out? The flows are stuck on input switching, setting and changing volume, and turning off/on.


Can you help me, Jorden?

Sorry, I was gone for 3 weeks during my vacation in the USA.

Is still problem still happening? And is your Homey up2date (1.5+)? I have seen a few notices of crashes for version 1.0.3 (guess I have set the required software version wrong).