Ngenic

Tried to control my Ngenic thermostat from Homey. I think this works:

  1. Install https://homey.app/en-us/app/com.internet/HTTP-request-flow-cards/

  2. Setup a flow with the PUT JSON (A40) card with the following parameters

Text 1 (url): { “method”: “put”, “protocol”: “https:”, “hostname”: “app.ngenic.se”, “port”: 443, “path”: “/api/v3/tunes/{tune-id}/rooms/{room-id}”, “headers”: {“authorization”: “Bearer your-id”, “content-type”: “application/json”}}

Text 2 (json data): {“targetTemperature”: 20.0}

Replace tune-id, room-id and your-id with the identification info relevant for your installation. A tutorial on how to access these can be found at https://developer.ngenic.se/

2 Likes

Hi Markus.
I have an Ngenic and would like to control it from Homey.
I could not find a tutorial to find the tune-id, room-id and your-id.
Or maybe the problem is that i am not a software developer :slight_smile:

Do you have time to explain how you found it?

Kind regards! / Mikael

Hi Mikael,

Look at https://developer.ngenic.se/ under “authentication” for your-id, it is referred to as “personal access token”

Then use the curl commands (available via a Linux/Mac terminal shell) under “a few usage examples” to retrieve the tune-id and room-id, referred to as tuneUuid and nodeUuid in the example.

Hope this will work out!

All the best,
Markus

Hi again :slight_smile:

Thanks alot now i understand. I managed to get hold of my Uuids so i think i got it right now.
I had to reset my password for Ngenic since i couldnt log into the developer altough my password worked for normal Ngenic use.
But it didnt work i just get a error message…

Hi Great tip Markus

I have done the same and have the same error message as Mikael :frowning_face:

Note sure what the error can be. I remember having troubles setting this up. Perhaps there were multiple ways of doing a JSON PUT? Think it had to be an A40 request, see HTTP request flow cards App for Homey | Homey. You see the A40 info when editing the card on the phone but I cannot see this in the web interface.

I see that the title of your card is “PUT JSON (url)”, while my card just reads “PUT JSON” in the beginning. Perhaps that’s related?

Hi, old thread but:
just used the standard logic board for http request, HTTP PUT

URL:
https://app.ngenic.se/api/v3/tunes/TUNE_ID/rooms/ROOM_ID

HEADER:
Content-type: application/json
Authorization: Bearer YOUR _TOKEN

BODY:
{“targetTemperature”: 15}

Får inte rätt på detta lägger du in det precis som ovan?

Skärmdump från homey.app. Funkar det bättre så?

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you.

1 Like

Super! Thank you