NEXA ZPR-111 plug-in-relay

I am having problems including these Z-wave devices. Once I got to the PIN question (and I tried 00000, as suggested for devices that dont support DSK; didn’t work), but usually I just get a “something went wrong, please try again” error message. (the one I get is in Norwegian, but that’s the gist of it; not a really helpful/descriptive error code.)

Also, the first three key-pushes, to get the first green checkmark, that’s easy, but exactly how to proceed after that, I’m just pushing the button more or less randomly and hoping for the best. (obviously, neither Nexa nor other devices explain how to do the two-step inclusion Homey uses…)

Any help much appreciated…

Hi Inge,

If you use an Homey Pro (early 2023) this isn’t really needed. With the PIN 00000 it’s possible to include Z-Wave devices unsecure, but not a must to do. If you have problems with your Z-Wave devices, like slow response, it might be helpful, because unsecure included Z-Wave devices reduces the Z-Wave traffic.
Btw, it’s only possible if the device supports the security standard S2 Authenticated, where you need a DSK (Device Specific Key).

Acc. to the App Store your Nexa smart plug isn’t supported by the Nexa Z-Wave App.
There are two things you can try:

  1. Ask the app developer if he is willing to add the Nexa Smart Plug. Contact options are usually stored in the App Store. In this case it’s a link to the source code on GitHub (Link).
  2. The Smart Plug should work as a “Generic Z-Wave Device” without the support of an App. Because there is no App for this device und the including process is a process for an unknown “Generic Z-Wave Device”, there is no correct description of the include process off course. So what you have to do is to include the device like it’s explained in the manual:

    The first step while the including process is to exclude the device, e.g. from the “old” gateway. The second step is the real including step. So you have to press the button again three times within 1.5 seconds.

I’ve used that last procedure. (Just three additional pushes after the first three most certainly don’t work, first thing I tried. I need to do “something else”, not really sure what sequence, before a second round of three will work.), and after I get two green checkmarks, it usually times out, or whatever. (“Something went wrong, try again”).

Once, I got at prompt for the PIN, even though Nexa confirmed it doesn’t have one (DSK not supported); I tried 00000, and got no further that time either.

Wasn’t aware of the Nexa Z-Wave app (but i had installed another, just named Nexa…), might try installing it, even though the plug isn’t listed…

Wait a bit between the first step (exclusion) and the second step (inclusion). And try to include the Smart Plug near to Homey.

If that also doesn’t work, please contact the Athom’s Support.

The official Nexa App supports only Nexa devices with 433 MHz, as stated in the App Store:

So please inform you first in the App Store which devices are supported by Homey / Homey Pro.