My Account No Devices

Wondering if anyone can help here. I have a Homey bought in 2019. It is working fine but recently I have tried to install some apps and I can’t. Looking into my account and I have realised that in the “My Devices” section it says, “You don’t own any devices yet.”
Now I am sure that I have seen devices in there before and I have a feeling that this may be why I can’t install any apps.
Is anyone able to suggest how I go about making sure that my Athom account recognises my Homey please?
Many thanks.

Sounds like you may have multiple accounts? Have you tried going into the Homey app that controls your Homey and tap your profile on top to see what email it is registered to?

I think you may be right. Just realised I tried to change my email. Honey is now registered to a new email address, I’ve just tried to change it back abs can’t. It says a user with that email already exists.
Is there a way I can put the email back to the original one?

Maybe log off, and log back on with your original email address

Tried that. Doesn’t like it. I was going to try and delete the new account as there is an option for that but if I do I worry I won’t be able to get in to the device at all. I’ve logged in with the new account and it’s all there. I’ll give it 24 hours to see if I can swap the emails back. Thanks for your help.

1 Like

Did you contact Athom support already? I think that’s the first thing you should do before you do something irreversible…