Lockwood Keyless Wireless Digital Deadbolt won't function

I have a ZWave compatible lock that I’ve been using with my Honeywell automation system that I was looking at replacing with the Homey to make better interactions available, but the device isn’t functioning.

At first the Homey couldn’t see the device until I moved it to within around 3 feet of the lock when it then paired instantly with, but now it’s connected the Lock doesn’t function when I toggle its status between open and locked with a flow or directly with the device itself within the Homey interface.

I’ve had issues pairing and working with other ZWave devices too.

You might want to give some more information.
What type of Z-wave lock? Is there an app in the appstore?
Witch other z-wave devices are in your mesh?

What type of lock?

Other than the manufacturer being Lockwood and it’s a Zwave / Zigbee compatible lock that worked perfectly with the Honeywell Zwave controller, I couldn’t tell you… I couldn’t find an app for it in the AppStore.

Other devices on the network? With the Homey, nothing yet as the only two Zwave devices I’ve paired with it, this lock and a dimmer switch that I unpaired from the Honeywell system that controlled them previously, other than pairing with them, the Homey won’t control them…

Ultimately I was looking to migrate the 50 odd Zwave motorised blinds, lights and locks to the Homey as the scenes and control of the Honeywell aren’t great.

The Lockwood Keyless Wireless digital deadbolt is a (AU) rebranded Yale Lock. Like also mentioned at: http://www.smarthome.com.au/yale-z-wave-assure-keyless-deadbolt.html

There is an Yale Z-wave app: https://apps.athom.com/app/com.yale.lock

You could try installing this app and checking if this solves the issue (could be that the device ID’s are identical).
If not identical, you could contact the developer to add the right ID’s to the app…

Or try similar steps as mentioned in Cannot include Aeotec Garage Door Opener

@danone where is the AU hangout?

1 Like

@TedTolboom there is one on Slack but only a couple of active members at the moment.

@HighwaymanEd I think it could be a good idea to try the Yale Lock app as Ted suggested. Maybe also this one: https://apps.athom.com/app/com.yalelock

Perhaps won’t recognise your lock since different Z-wave frequency, different product Id. But if you can read the Product Id after pairing and try side load the app after entering the product Id as per instruction Ted pointed out.
If you get stuck you can PM me and I can try help.

1 Like

@TedTolboom Thank you that worked perfectly, although the Homey still has to be within 3 feet to pair and control the lock. This wasn’t the case with the Honeywell system that is controlling ZWave devices all over the house…

Any idea if there is something likely to be interfering with the Homey? I don’t have anything out of the norm here, just a Ubiquity Wi-Fi network on 5GHz and 2.4GHz and the Honeywell home security system that currently controls all of my existing ZWave window blinds and light dimmers…

Hi guys,
I have the Model:YRD446NR-ZW is this the same as yours.
I’m going to try install tomorrow but have not seen it in the apps

Mine was recognized as the YRD220 when I paired it with the Yale Digital Lock application.

Thanks, I’ll use that and see.
As a side note, would you by any chance know how to unpair the lock.
I previously had it connected to a Vera Plus which I sold and realise it would have been easiest to unpair it first.
Will when I try to pair it to Homey let me go into unpair mode and then re pair if that makes sense?
Appreciate your time😀

Sure, in the Settings section of the Homey app, select ZWave and then tap ‘Remove a device’ once you do that, you need to then enter the code into the lock to un-pair it (on mine, enter the master pin, then #7 #3 # )

1 Like

@HighwaymanEd Homey does not support inclusion of Z-wave devices over the Z-wave mesh network.
So therefore, you’ll need to include your devices in direct sight of Homey.

When moving back you Homey, it might take some settling time before the lock finds a different path through the mesh to Homey. Do you have other Z-wave devices (with routing capability == mains powered) included in Homey’s network (!) that are in between Homey and the lock?

OK, that’s interesting, I wasn’t aware of the pathing considerations and wrongly assumed that I should still be able to get a 10m range through plaster walls.

All of the devices in the house with the exception of the Door lock are connected to the mains power (lighting circuits). The devices that I tested with though were not in sight of Homey so that would probably explain why I’m having issues with connectivity.

I’ll have a play around with a couple more devices to try and build a path. Do they have routing capabilities? No idea, but they all work with the Honeywell system currently so I’d guess that they do…

Typically, any mains powered Z-wave device will have routing capabilities…if they are connected to the same Z-wave network / controller… so devices connected to the Homeywell system will not create a mesh network for devices connected to Homey

1 Like

That’s great info to have, thanks. I’m traveling for work for the rest of the week now, but when I get back home I’ll un-pair some more devices on the ground floor and connect them to the Homey to help create the network and have another go.

I really appreciate your input here, they should feature you in the intro videos to Homey explaining how the Mesh network for ZWave devices is formed!

Thanks Ed,
Got it. Tried to pair and will only do as a generic device and it won’t open or close by the app
Also tried to pair Aeotec garage and same thing, does as generic device and won’t open or shut. Do you have any suggestions or, do we need to just wait until devices are updated.
I also have dual aeotecs and they aren’t supported and waiting for update. Basically have whole house inoperative due to Homey not compatible

@Angelo_Di_Genua write down the ID’s of the devices added as generic Z-wave device and follow above mentioned steps to manually add them to the app.

@MatthewWaanders can you add the AU ID’s for all devices to the different apps (ie. Aeotec) to help our friends from Down Under?



You sir are a true wealth of knowledge. As I paired more devices, so the reach extended. Now I’m off on the hunt for apps / drivers / tweaks to get some of the other kit working to it’s fullest potential!

Thanks for the feedback!

We’ll try to change some apps / drivers yourself… and next step will be to create your own app :stuck_out_tongue_winking_eye:
Enough examples available as reference…

The garage door controller and more should be fixed in Aeotec 1.6.7!

Thanks for the quick support @MatthewWaanders