Light groups not always working


I have the following situation: in a room there are 5 seperate GU10 Innr Zigbee light bulbs. When a button on a remote is clicked, I have the action to turn on all lights in that room. Homey then turn on all 5 seperate lights. However, there are 2 issues:

  1. In 90% of the cases they don’t turn on/off at the same time. Sometimes there is up to 2-3 seconds delay. Making it look very messy.
  2. In about 20%-30% of the cases 1 or 2 lights don’t turn on/off. I have to press the button again to make the rest go on.

I also already have tried the app and placing all 5 lights in a group, but it’s the issues as above.

I have a similar setup with Philips Hue. There all the individual spots turn on/off at exactly the same time. I would like to achieve that as well for Homey.

Anyone experience in how to tweak this setup? Thanks in advance!

Which app? Z-group? That one fixed most of my problems. What make are the Zigbee bulbs?

Do you have a dedicated on and off button? Cause then it’s easy to at least sync the states. I have a toggle button, and then it was important to be able to sync the states more easily, since once they’re out of sync, toggling them on and off keeps them out of sync. In that case, I made a variable which said if the light in the room was turned on or off, and toggled that variable instead. Then I had a WHEN variable changes, THEN turn on

This issue has existed for years, and Athom seems to be unable to fix it.

The regular workaround is to add delays in between the commands:

  • turn on/off light 1
  • turn on/off light 2 after 1 second
  • turn on/off light 3 after 2 seconds

I think that the <group> app also has an option for this.

Thanks for your reply. No, I’m using (< group > App voor Homey | Homey). Can’t find another group app (nothing called “Z-group”)?

Sorry, I meant < group >!