LG WebOS better integration

Quick update. I was watching a tv episode on Plex today when two flows fired in the middle of the show. Turns out the “tv turned off” and then “tv turned on” were triggered. The tv is a 65nano926pb.

@Tiwas

Sorry, I wasn’t clear…I was thinking mainly for the Plex application, where episode is just the episode name. I’m not much of a coder as such…

Unsure if that is possible in the WebOS Plus app.

I think I"ve found a bug. It seems that if I turn the tv off while playing something in Plex, the “tv on” and “tv off” will fire 3 times after one another. Anyone else seen this? If I stop the media first it doesn’t happen.

Can you post a screenshot of the TV settings in the WebOS plus app. Or send it in a DM :wink:

Please check your messages. Tell me if you need anything else :slight_smile:

1 Like

I"m still having issues with the on/off thing. Seems it only happens if I"m using an app. Anyone else experienced this?

Hi,

I use the app only to turn off the TV and lately it works in 50% of the cases. While previously it was 100%.

The flow is simple and runs successfully.

Any idea how to debug and find out what the problem is?

Still works fine here.
With the NetScan app, you can create a device which can monitor your LG IP address.
This way you can find out if the connection is the culprit or not.

1 Like

Hi!
Little bit late response, but I just bought myself al OLED65G1 and have the same problem (sometimes).
During watching the TV suddenly switches off… Looking in Homey WHY I can see it was done bij LG Webos application.

I restarted the Homey app and the problem was over, but it happend again for 2 or 3 times…

That is definitely a first for me to be honest. The App should not send a shutdown command if the TV is still detected as off. I am not familiar with that model and please note I cannot test this app on WebOS 6+. Maybe you can change the on/off detection mechanism to polling instead of the app relying on the TV itself?

i can’t confirm that i have the same tv.

I also have issues with on/off.

My flow has been falsely activated a couple of times now…

@Robert_Larsson @Marco_Dijkstra Could you post a screenshot of your settings in a DM to me?

In general:

Sadly, but obviously, I cannot test all the different kinds of LG tv’s and I have noticed they are not all working the same way as mine. I have 2 LG tv’s (different models) and for one I can use the listen command to detect if the TV is on/off, for the other one I need to poll it via the network every x secs. This means it is really, really, hard to debug these kinds of issues and my suggestion is to enable the polling mechanism is on/off is not working as expected. If you have any programming knowledge, let me know and we can team up and improve this app :slight_smile:

I have issues with my LG 65G as well, I have to restart the app on a daily basis. I don’t see a crash, but it just does not respond anymore to on, off or other activities on the tv (e.g. start app). This started 1-2w ago.

So far I tried reinstalling the app (via hcs) and PTP of the tv, but no difference.
Any suggestions? Can I somehow help with debugging?

I recently binded the LG to hass, but have this not running at the moment. Could the issue have something to do with this?

I have made a request already, the current LG WebOS app is for:
“This app supports webOS 2 & webOS 3 TVs made by LG” and the current version is already 6.0.

I got an answer that they will work on it…

That is for the LG app created and maintained by athom I believe?
This app WebOS better integration from Max supports more and works much better.

2 Likes

I use the HCS app by Max too, it works like a charm
LG WebOS UJ630V
Software version 06.00.20

1 Like

Hi @MaxvandeLaar

Is there any reason why I can not install your app??
The HCS is correctly installed, I already have other apps from the HSC, ik gives the message that the app will be installed shortly, but nothing happens….

LGOLED65G1 webos 6.0

Give it some time. It will start, and try and restart a few times. Has the same thing with another hcs app too

Ate you logged on to HCS? The install button should be green.
Is the Homey HCS app running (not paused / turned off)?
Do you use router / laptop firewalls, piholes, adblockers?
What has changed in your setup since the last successful HCS app install?

Yes, im logged in; The install button is green en the message ’ will be installed’ was shown; Yes de aHCS app is running; No, no blocking from firewall etc; Nothing has changed since the last succesful HSC app install (last week).
still no app installed…

Weird… does any other app install, Marco?