Leviton Vizia Plus switches - mixed results

Hi all - I just decommissioned an old smart home hub from another manufacturer and I’m in the process of getting my Homey Pro up and running. The backbone of my system are Leviton Vizia Plus Z-wave switches and dimmers - mostly dimmers. They worked flawlessly with my old hub for the last ~8 years or so.

Here’s my experience so far - looking for advice/help.
I installed the Leviton App to Homey, and clicked “+ New Device”
I chose the Leviton Brand/App
I chose “Smart Dimmer,” as that was the most obvious choice.

For some of my dimmers, I complete the pairing process and get a message that says “Could not find an installed app for this device. It has been added as ‘Unknown Z-Wave Device.’” For these dimmers, it appears as a device, and I can control it. It is a little buggy though. On/Off works fast and flawless. Dimming is buggy. The LED indicator on the switch does not appear to sync with the app. Dimming to anything over 50% on the app brightens the light and the LED indicator on the light to 100%. Sometimes it just stops updating/dimming.

Now - for other dimmers - same Leviton Vizia Plus - I get a message when pairing that says “Something went wrong while communicating with the device. Please try again.” No matter how many times I try, it will not pair these switches. I’m not aware of any differences in the switch itself. I have relocated my Homey Pro to right next to the switches that are giving me problems, but I still get the same message.

Any advice? I guess #1 - why do the ones that pair not recognize the Leviton app despite there being an Leviton app? And does this impact the dimming performance?

#2 - any idea why I can’t pair the other ones?

This is a deal-breaker for me if I can’t get these switches to work. They worked with my old Z-wave hub. I’ll return to that if I can’t get them to work simply because it’s cheaper to do that than it is to replace the dozens of z-wave switches I already have installed.

Often the specific devices should be shown in the appstore as well to be supported.
In other words, when a brand has an app available, it often does not mean every available device model is supported.

In your case, I suggest to contact the developer. Support links are to be found below the reviews in the app store app page.

While I checked already, here you go https://github.com/koktail-nl/com.leviton.issues/issues/new/choose

Thanks for the reply Peter. I have never used Github before, but I think I managed to submit a ticket…

With that said, I’m a little disappointed as my switches are Z-wave, and I was under the impression that Homey Pro could control all Z-wave devices (and a lot more)…now after waiting many months for my unit to arrive, I find that it can’t control the one device I need it to control the most. Very disappointing as I generally like the interface. If I have to wait for additional development at this point, I’m likely going to look elsewhere.

Does anyone have any idea if there is a generic device profile or something else that may allow the problem switches to pair? It starts the pairing process just fine (i.e. it recognizes that I am attempting to pair with that device), it just won’t complete the process.

It’s a common dissapointment, while the marketing shouts ‘almost everything +50,000 devices of 1000 brands can be controlled by Homey’. Like any marketing and promotion, it’s not quite like reality.
But on the other hand, Homey is a nice and versatile tool with a great community around it.

Most apps have an own forum topic here, but the Leviton app hasn’t (yet). Yeah, Github is a place where developers can save and manage there apps, and bugs, issues, feature requests etc.

To be honest, your Leviton devices should work as far as I’m concerned. I’m sure the developer will get back to you.
In the meantime:
Before you started, did you really factory reset the devices which won’t complete the pairing process?

When starting the pairing process, do keep the device and Homey not further than a few centimeters from eachother!

I’ve tried pretty much everything - I’m not TECHNICAL with Z-wave stuff, but I understand how it works and how to pair it. I’ve been using it on a different hub for 10+ years now…I’m with you re. feeling like it should work. It’s Z-wave…it shouldn’t be that different, especially since these switches are on the older side - it’s not even like it’s a new standard or something.

I did a factory reset on the switches and that still didn’t do it. I think my last step is to force unpair it just in case the device thinks it’s still registered, then reset it, then try to add with the Homey right next to it…that’s as “fail-proof” as I think I can get. If it won’t do it then, I’m convinced there’s a compatibility issue. I can re-pair the problem switches on both my old hub, as well as my Honeywell alarm panel, which has a z-wave hub built in (but I don’t want to use that due to no scene capability). I know the switches do/can work - just not with the Homey apparently.

Hopefully I can get some insight soon. I’m surprised so few people seem to use the switches I use. They were discontinued a year or two ago, but you used to be able to get them at Home Depot and the box stores around here.

Still trying to figure out what’s going on. My last hypothesis was that there are slightly different model numbers of switches that are all Leviton Vizia +…while that is incorrect, that doesn’t appear to be the issue as, for example, I have VRI06 model switches that both are and are not able to be paired.

Some of these I bought used, so I have attempted to exclude them. My old Vera controller has a dedicated exclusion mode for cases where a device may not have access to it’s old controller - I’ve run that exclusion mode with the devices several times. I’m not getting the feedback from the switch that I would expect, but the Vera indicates they were excluded. When I then try and pair to the Homey, I get the same response. “Something went wrong while communicating with the device. Please try again.”

In the developer tools, I can see an Unknown node was created from my pairing attempt sometimes…not always. Sending a Basic On signal in some cases will turn the device on, but in other cases will not.

My Homey has been relocated literally touching the in-wall switch - so distance isn’t the issue.

I feel like there is something with the switch that is not fully excluding it from the previous controller. Does Homey have an exclusion mode to exclude switches NOT PAIRED WITH HOMEY PRO from the switches’ current pairing? Like how do you exclude a switch if bought used and you don’t have the controller/hub that it was previously paired with?

Maybe zwave guys @caseda @DirkG can answer the last question?

Does Homey have an exclusion mode to exclude switches NOT PAIRED WITH HOMEY PRO


So I guess just so I’m clear - I found those buttons, but they didn’t seem to do anything. I used the delete node under the unknown nodes to remove those, but for a device that isn’t paired (successfully OR unsuccessfully) with Homey, it doesn’t show up at all in the device list. I’m still not clear on the sequence I’d need to use to remove a node not paired with Homey. My understanding is Z-wave devices can retain their “paired” status even if the device they are paired with is long gone (i.e. buying a used switch that wasn’t properly unpaired), and that you can’t then pair it up with a new device (i.e. my new Homey Pro) unless you unpair it first.

How using the above tools would I unpair a device that isn’t paired and on the device list (even as an unknown node)? I’m sorry if I’m missing something that’s obvious…

“remove any node” should technically be called “exclude any Z-Wave device” or “reset any Z-Wave device”.
That will put Homey into exclude mode and this is the button you seek.
A device doesn’t have to be included for this button to work.

But also if you add a device in Homey it will first reset/exclude said device (step 1) before it tries to include that device into Homey (step 2).

I guess it isn’t called “exclusion mode” to stop some minor confusion for new devices as there is “nothing to exclude it from”.
And it also isn’t called “reset any device” cause it won’t reset all device brands to factory default, like qubino which keeps all its parameters (settings) when you reset it by exclusion.

Thank you. That’s super helpful. I was able to manually exclude one of my problem switches. I excluded it, did a factory reset on the switch, and attempted to pair again. Sadly - same error. “Something went wrong when communicating with the device.”

It created an unknown node when this happens, and from the developer dash I can turn the device on and off, but it never completes the pairing.

Is there an error log somewhere that might give insight into what is happening? I’m confident it’s not a hardware issue as it will at least communicate. I’m just not sure if it’s a software issue or if somehow my switch still isn’t letting go of the old pairing or something.