ITEAD Sonoff

See here under “Getting Started”.

It’s not a trivial process though, it may require some soldering and you’ll need a USB-to-Serial dongle.

Thanx. I Will take a look at it

More news you may find interesting… Itead Sonoff Homekit support coming soon (probably :slight_smile:

I have a possibly random question…

I set up an un-hacked sonoff via this app with Homey, all works good

My question is, lets say my internet drops but WiFi is still up - will this still function if Homey and the sonoff are on the same WiFi?
How about if they’re on different WiFi SSID but same network?

Thanks :slight_smile:

I think it will, yes. The unhacked version sets up Homey as its cloud server, and it uses the internal IP-address of Homey, so even if the connection to the outside is gone, the device should still be able to communicate with Homey.

Should also work. I don’t think the Sonoff device really cares (or knows) about Homey being on a different SSID, as long as it can reach Homey through its (internal) IP-address.

Great - thanks :slight_smile:

So I’ve just updated my WiFi network and so am trying to update my TH16 to work with Homey. It’s plausible I might have updated the firmware on it originally so this may not work but I have managed to get to the potential success message then it just sits there doing nothing

Having now given up I’m actually trying to pair it with the eWeLink app and it can’t actually find the device…
Is the process that your app does likely to have messed up both ways for me?

Edit: Actually - is there a firmware version that the original method stops working natively?

I think that for the TH16, it’s firmware 1.6 or up.

The TH16’s seem to be a bit buggy:

Take a look here for LED blink status:

Typically, you can put the device in pairing mode (for the original app) by long-pressing the button (or perhaps keeping the button pressed while powering up the device).

Hmm… might actually be okay then - just checked my other sonoff (basics, not TH16 which I would have updated at the same time) and they are 1.5.5

MIght give this another go with Homey then!

Tried the Homey method again, and have moved one of my mesh nodes much closer, but the thing just seems to keep flashing to try connect. I wonder if it might be an issue with the network being a mixed network?

Edit: Seems nothing to do with the mixed network - just tried it on a different 2g only network and still no luck with it connecting…

Edit2: On the 73rd attempt with the original (mixed) wifi i’ve managed to get it through to the double flash! But clearly it’s struggling to reach Homey now - I wonder if this is because it’s on a different network?
as opposed to the 192.168.1.x

In theory, as long as a route exists between 0.x and 1.x, it should work, but I wouldn’t be surprised if the firmware has a hardcoded netmask of or something.

Yeah, there’s totally a route - I can manage homey locally via ip on any wifi device that’s on my mesh.
I think both are on the subnet tho too anyway…

Edit: is there anything I can do on Homey that will help ‘kick’ the server response into gear?

Holy **** - i’ve done it!

Restarted the Sonoff App and left it a while it just worked !

Hi @robertklep

Device seemed to have lost the connection this morning - still WiFi but no Homey response :frowning:

This might be a null question, but I’m pretty certain (tho happy to be corrected) that the schedule from the ewelink app was actually stored locally on the sonoff unit as seemed to work irrespective of internet connectivity - am I right in this assumption and if so is there any way to apply a perm schedule after your flashing process?


I only have limited knowledge of the official firmware, so I have no idea how it deals with reconnecting after it has lost the connection to the (fake) cloud server.

It makes sense that such a schedule is stored on the device itself. However, because of lack of information (and openness), I don’t know how schedules are implemented on the device and in the official app. Also, because support for the official firmware can break at any time (when ITEAD pushes out a new firmware), I’m not actively working on further support for it.

That said, even though the Tasmota firmware supports timers/schedules, those aren’t directly supported by the Homey app either. However, they can be configured using the built-in web server (I think) or by sending the device messages over MQTT.

I have a few Sonoff basic, working fine with the Homy plug in - Great.
But I would like to add the functionality of the Sonoff GPIO’s - i.e. put a Button on GPIO14 and add a trigger in Homey.
I use MQTT in Homey.
Is this possible, and how should I setup the Sonoff and Homey.
I have tried a few combinations without luck.

1 Like

Not yet possible with the Sonoff app, but I’m working on a generic Tasmota driver that should be able to do that.

1 Like

Nice, Looking forward to see it :slight_smile:

1 Like

When I’ve restarted my Homey I loose connection with all my 10 pcs of TH10 with tasmota FW. I’ve tried rebooting MQTT and Sonoff app in all different variations. But if I delete them and readd them it works instantly! A bloody hassle to redo all my flows tough…
I’m using the MQTT Broker on Homey.
Any ideas what can be done about this?


Could it be a WiFi-issue? Have you tried rebooting the device(s) when the connection gets lots? I’ve heard about Sonoff devices having issues reconnecting after the WiFi has dropped out.

I have a few Sonoff devices in my network that never give me any issues, and they’ve been running for months.