Issue Homey setup

I am trying to setup a Homey Pro (used device but been reset) following the ordinary setup guide, but after a few steps I get stuck in a loop with no end. Just keeps me in a never ending loop between step 3 and 9 below.

  1. Homey flashes yellow and asks me to open the app and follow the instructions.
  2. I login using my account
  3. “Add a new Homey”
  4. “Configure Homey Pro”
  5. Upon request I open Wifi-settings and connect to the “HomeySetup–XXXXXX” device.
  6. Going back to the Homey-app again, I click the “start settings”-button.
  7. I choose language “English”
  8. Now it asks me to “Get the Homey-app”, though it’s already installed. No other options available.
  9. It takes me to Apple Appstore where I can open the Homey-app again - which takes me to step 3 again.

So I’m stuck in this loop between step 3 and 9 without no options to proceed further with the setup.
Haven’t found any solution in the forum. Does anybody know how to get through this?

Not to nag or troll, but it works on Android. Maybe you can borrow one and use it just for the setup?
install Firefox on a pc / laptop and follow this link

No worries :slight_smile: Yes, I have tried Android without success. Same result as with iOS.
I tried Firefox on a pc now, but it only takes me to download the app at Appstore or Google Play. Doesn’t seem to get me anywhere unfortunately.

Press the alt button (Option on MAC) until the extra option “continue in the browser” appears.

It’s odd it doesn’t work on Android as well…
I used it several times with the Android Homey app without any issues.
Did you install a recent app version?
Does this howto make a difference?

Thank you very much Peter. After many tries I could proceed with the setup in Firefox and it started to download/update the firmware. Though it is now stuck in update mode (purple light) and nothing happens. I let the Homey be during the night hoping the update would finish after many hours, but no luck. The purple light keeps flashing and the Homey is unreachable. I have tried to pull the plug, waiting for more than 15 minutes before restart. And also the upside down-manoeuver after 5-10 seconds but purple light keeps flashing. Also have tried using a different more powerful adapter. Just lost.

It sounds like the “red ring of death”… not much you can do.
Contact support:

Yes, ended up in having to send the Homey pro to Athom NL for a software fix.