IOS app loosing connection to Homey and repeatedly reconnecting


new Homey Pro 23 user here. My app in IOS seems to loose connection to my Homey. I see the Home Screen flash by and then it says “reconnecting in 4 s”, Home Screen is flashing by again and then it goes on.

I can go into the other parts of the app and set up devices and get them to work. Can create simple flows and start them.

Also on the web app it seems that the web app doesn’t read out any status, can’t even see the version number of my Homey. But an item on the timeline says it updated to 10.0.8 some days ago.

Tried both Wifi (fixed IP and locked to AP), Ethernet adapter (fixed IP). Can ping it. Rebooted Homey (a lot… ) and reinstalled the app too. No change.

First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum! post here.

It doesn’t lose connection in reality, it is some kind of a (long lasting) bug.
The app can’t communicate with Homey somehow, while Homey is online all the time (like you checked with pinging Homey).
I think you’d best contact

Regarding the web app, empty your browser’s cache and force refresh the page.
It should be able to show all Homey details.

1 Like

Thanks for answering. Did put a support request too. But since they have a long support queue I decided to try here too.

Clearing browser cache didn’t help. Same phenomenon on different computers with different browsers so I guess it is a Homey problem.

Can also not have any time conditions in flows, It generates an error when I save. So something is rotten, don’t know if it is “early access symptoms” so there are lots of stuff that doesn’t work.


  1. Can you show one of those time conditions, and the error message which pops up when you save?
  2. Can you show me the date, dateHuman and timezone from this page ?

First I’d like to find out if it’s a user error (no offence), or something else.

There’s several “early access symptoms”, no doubt, but “lots of stuff that doesn’t work” is not true.

Thanks again for helping. I am traveling this week so can’t reach my Homey. Furthermore I got a really fast response from support that suspected that the last firmware update somehow didn’t get properly installed and recommended me a procedure to fix that. Will try that next weekend when I am back.

And, having been a lifetime in the IT-business I don’t get offended by suspected user errors. I have done far too many during the years to exclude myself as the source of error :smiley:

1 Like

I got the tip from support to do an OTA-update of the firmware. After that all the errors disappeared.

Thanks @Peter_Kawa for offering to help.

1 Like

hi all,

I also noticed the reconnecting behavior sinds couple of weeks. I blamed my wifi network but with this info I’ll also open a ticket.

its on android by the way.

Hello Hans_K1,
Can you share the way you fix this as I’ve got the same error?