Install app(s) via cli


It is not possible to install any apps via cli, it says that Homey is offline (which is not). This happens with multiple apps that I want to install via cli. However I can install apps from the store. I tried to reboot it, but that didn’t help.


Details Homey:
Version 2.0.1
​Node.js version 8.12.0

  • The SSH Client app has not been updated yet and isn’t compatible to install via the store. This is also the reason to install the app via cli.

Do you have any idea what the problem is?

You should create an issue here:

It’s especially strange that you can log in, but subsequently, the CLI tool says that your Homey is offline. Sounds like a bug.

Do make sure that you’re using the latest version of the CLI tool (2.1.68).

Installed several apps yesterday with the CLI but didn’t have any problem

The CLI tool is indeed 2.1.68. I guess i have to create a ticket at github.

Did you connect Homey using USB or are you in the same IP subnet as Homey when it reports it is offline?

He was not connected via USB, but he was connected via the same IP subnet.

I could try it via USB tonight (preferably not).


I just tried it on another computer and that worked for some reason…

Hello Patrick92
I have the same issue do you know more,i never used usb so that should not be the solution

Issue here:

Are you using an Windows computer? My mac did the trick. On the Windows computer I received the “Homey Offline” message. Could be OS related?

i used a win10 machine,all the time homey offline
then i have a virtual machine running from oracle with linux mint,so i installed the enviroment under mint
and voila homey offline

Maybe you should try it via USB?

Windows firewall I guess

3 years later?

:rofl::+1: didn’t pay attention to that

1 Like