Hue lights do not turn off in reality but Homey displays them as having been turned off?

Hi folks

Just setting up some of my first Homey Pro (2023) flows ever, so please bear with me here, if I am asking about something obvious. :slight_smile:

I have created a flow for my kitchen lights which correctly turns on my lights based on my Hue motion sensor.

Then I have set up a “When Zone [Kitchen] has been inactive for 3 minutes” card which then turns off all lights in that zone.

This last bit only seems to work partially.
When 3 minutes have passed the lights briefly turn off then immediately they turn back on. Homey then displays them as turned off but reality is that they are turned on.

Before Homey I used Home Assistant to control my kitchen lights and it worked perfectly.

In my Hue app I have made sure that the Hue motion sensor is turned on but doesn’t trigger any automation.

I made sure to turn off the Home Assistant automation before activating the Homey automation, so I am confident that that is not the issue… But I quite hope that you guys have a suggestion for what I am missing.

What I have tested:
I made sure that the card “Turn off all lights in Zone” was switched to call the specific lights instead.
I tried using a timer instead of “3 minutes after last activity” card.

Additional info about the lights:

  1. The lights in the kitchen have a Flic button associated, which can turn the lights on/off.

  2. The lights in the kitchen is currently the only group of lights with a motion sensor in Homey. I also have a group of lights in my entrance with a motion sensor, but these lights are currently controlled by Home Assistant (I dare not switch to Homey as long as the kitchen lights are not working properly).

  3. The lights are from Eglo - a zigbee product but have been connected to the Hue Hub in order to work in Home Assistant (where it worked fine before I turned off the automation in HA)… These lights could be disconnected from the Hue hub and connected directly to Homey - though not sure, if that would fix this particular issue.

Here is the flow I have set up.

You set Relative dim level not absolute dim level, is that intended?

Instead OFF you could try dim to 0% (absolute), and maybe place the 3 cards after each other.

1 Like

Thanks a bunch.

Good call on the relative dimming! I changed it to absolute. :+1:

Your answer made me aware of some other things I could test - and I think I found a way to make it work… But it also indicates an error somewhere in the system (not in my flow).

Dimming to 0% was extremely slow but seemed to work. It turned out that the reason it worked was that dimming to 0% actually failed - and the lights turned off as a fallback solution for that error.

Then I tried testing a sequentual “turn off” flow. Howewer, here the issue became quite obvious. One after one each light turned off and then on.

Finally I tried testing the “Turn off all lights in group” card. This seems to work for some reason.

As mentioned earlier my lights in the kitchen are not from Philips but are from Eglo (Link to Amazon, so I suspect there is some issue with the command that Homey sends to these lights.

I connected my Eglo lights/bulbs to my Philips Hue Hub which is why I am using Hue to control these lights.

They integrated perfectly fine with Home Assistant (also through Hue), so I am now inclined to think this is a Homey issue.

I guess the last question now is: How do I report this error to Homey?

Here is what my flow (which seems to work now) looks like.

App Store → Support → Need Help? → My Homeys → and so on…
(You must be logged in, and you report it to Athom, not Homey… :wink:)