Homey Community Forum

Http trigger not working - error 417

Hi, I recently bought a Homey Bridge and I want to configure some flows.

I’m trying to setup a flow that is triggered by an HTTP request and then sends a push message. When I test it from the app it works fine every time. However, when I try to trigger the url in the webbrowser it fails.

I use an url similar to:
https://MyCloudId.connect.athom.com/api/manager/logic/webhook/Locatie?tag=Test
The response is a JSON error message:
{
“error”: “mesh_node_offline”
}
with HTTP status code 417 (Expectation failed). But sometimes these requests DO work and just show no output and status code 200 (OK).

What could be wrong here? Can I use http triggers with the Bridge or only with Pro (may be what 417 indicates?). The Http request card seems to be only available for Pro but nonetheless I can use the Logic condition in the app and it does work when testing it.

Is there some way to see more details of what’s going on?

The URL is different from Homey Pro.
It’s also mentioned as example at the logics card “a webevent has been received” :wink:

Thanks Peter, good to know that there is indeed a different base url for the Pro version.
I tried it again this morning and now it works like a charm with no changes in setup from yesterday.

Yesterday, my first attempt was indeed to test with the url you mentioned and consistently got status 200 OK but my flow did not get started. Looks like the requests were queued since at some point I did receive a bunch of notifications at once. I’ll keep an eye on it to see how reliable it works and if there’s any delay.

Thanks!

1 Like