How to update the firmware on Shelly Wave devices?

Hello everyone,

Was anyone able to update the firmware of the Shelly Wave devices? Any reccomended method? I’ve tried directely from Z-Wave PC Controller and by adding an aeotec z-stick 7 to homey pro, but the OTA Firmwar Update command fails (while it works for a different device).
Any suggestions on a reccomended method which works?




try the shelly forum:

look under known issues:
→ Inputs of the Shelly Wave i4 are not updated

There is an issue with all firmware version prior to 11.x with the Shelly Wave i4 where it doesn’t register input changes. You will need to find a way to update the firmware of your Shelly device. Currently Zwave OTA updates arent supported by Homey. A possible solution is to setup ZwaveJS2MQTT with an external Zwave stick and update the device from there.

try if this maybe works!

(i just orderd my zwave usb stick to try to do above)

Yes and no. It’s not possible to update Z-Wave devices with Homey, but there is a workaround with an Aeotec Z-Stick Gen 5 (+) and the Homey Aeotec App. And I guess, this is what @Andrea_Cavaliero tried to do.
For more information: Z -Stick Gen 5 (+) as Secondary Controller in Homey : Aeotec Help Desk
What I don’t know is, if it’s possible with Shelly Z-Wave devices. Because I didn’t found any firmware files for Shelly Z-Wave devices.

1 Like


i might have found the shelly update files:

edit the following link with the device name found on (link above)


for example:

then you will find a file you can download…

you will see something like this:
also a download link

1 Like

FYI I tried the workaround, first with Z-Stick 7 and then with Z-Stick Gen5- and it didn’t work. So I paired the devices with the Z-Stick Gen5 (It didn’t seem to work with Z-Stick 7) in order to do the update. Shelly firmwares are available here:

1 Like

hi Andrea,

can you please explain more, what you did after you connected them to you Gen5 stick?

in order to get the update to work

Hi Niels,
You can follow this guide, it works for shelly devices as well:

It’s actually simpler than it looks!

It’s interesting that it doesn’t work with the Aeotec App and an Aeotec Z-Stick, because the main firmware procedure with the Simplicity Studio Software by Silicon Labs is the same.

I think the Z-Stick 7 hasn’t got a Silicon Labs chip

It has an SI Z-Wave chip:

(Z-Stick 7 technical specifications)

Silicon Labs EFR32ZG14 Z-Wave 700 Modem SoC Data Sheet

I asked already an Aeotec employee why it didn’t worked with the Z-Stick 5/7 and the Homey Aeotec App. So lets wait and see.

@Andrea_Cavaliero, I have received an answer from the Aeotec employee.

The problem could be that the encryption keys Network Key S0, Network Key Unauthenticated and Network Key Authenticated are different.
So you have to check these keys in Homey Developer → Z-Wave → System Information and in the Silicon Labs PC Controller software:

image (1)

If these keys are different, insert the keys from the Homey into the PC controller.

Maybe you can check if it works?