How to run flows only once and option to overrule a flow

Dear Homey Collegues

Not fully new to homey but struggling with some questions and I hope you guys can help. Did not find anything via search, hope I do not double post. The following questions I have:

  1. does the time rule „after sunset“ ends somewhen or do I always need an ending time (e.g. „before sunrise“). I assume it does not end, but would be nice to get confirmation.

  2. is there a way to make a flow run only once. Especially for light flows. The flow „shut all lights off in evening“ triggers to shut off all lamps in the evening when we go to bed. For the night I have a flow „night lamps on“, which turns on some lamps during the night when there is movement. But the „shut all lights off in evening“ flow would then turn off the „night lamps„ flow again.

I could stop the „shut all lights off in evening“ flow with a time rule (from 21:00 till 23:00), but the rule is not smart, since bed times vary. Is there any other option, like run the flow „shut all lights off in evening“ only once.

  1. similar to 2. is there an option to overrule a flow. Situation. A flow turns on and dims a lamp to 20% („dim flow“) in the hallway at 7pm. If I now want to overrule the flow, because I need 100% light, e.g. with askin Aexa to turn on lamp to 100%, the „dim flow“ always dims the light back.

I was wondering if I could use the voice command to Alexa ending the „dim flow“. This would be also helpful for other flows, since I could then when I talk to Alexa, using this trigger to overrule a flow. No idea, if that could work. No idea if that is smart either.

If anybody has a solution, I am happy if you can help. I can also post the flows if it helps.

Thanks a lot.

You can disable flows in the then situation of another flow, reactivate after x seconds…

So you can deactivate the flow once it has turned of all the lights and reactivate it in the morning after. For your other light you can deactivate the dim fliw when the light is at 100%

I don’t quite understand why your flows rerun all the time. Maybe you could share screenshots of your flows for a better understanding of the situation?

I also have a logic for night time but it is very simplistic actually. I just set a different dim level during nighttime. Also after sundown is before after sunrise.

But my nighttime flows only run when really needed and overruling anything is possible at any time without sideeffects. So I suspect you overdid something somewhere but can only tell if you share some more details on your flows.

Thanks a lot Dracoignis. This might be an option. Then I need to reactivate the flow again. Have to check, if that works. Good idea.

Thanks a lot for your response. Yes, I am not sure, if I made smart rules. This is the situation, see attached pictures. I have a rule that shuts off the lamps at 2300 (Lights off at 2300) and then there is a rule that turns on lights during the night (night light on). But the other rule turns them off again. Sorry rules are in German.

Hi @Ringler,
No worries am speaking German too.
Well, it looks fine to me. I don’t know what is turing your lights off again though. The first flow is a one shot at the specific time.
There must be something else which is turning your lights off.

So your “alles aus 23:00” flow would run only once at that time.
I cannot see anything turning your lights off again. Maybe you got some other flow in place which you forgot about?

Thanks lot for your reply. Very strange. I do not have any other Turn Off flow. Let me test again.

Do you have any answer to my other questions.

Regarding 1. If I understand you right, if I would use after sunset instead of a specific time, then the lights would turn off. Correct?

Regarding 3. Any idea?

Thank you so much for your help

about 1) The sunset trigger is fired only once, as the at time trigger card would do.
The condition card after sunset should yield true until sunrise.

about 3) This is as strange as your turn on/off problem. The dim command is a one shot event and should not repeat by itself. So if you “overrule” after the flow ran, the setting should stay.

I have the weird belly feeling that something else it mingling with your lights settings if it is not Homey itself. What I try to say, Homey is not rerunning these flows by its own if you do not tell it to do so by some means. So it is very strange that your lights change state after Homey ran the flows.

About 1. Thanks for confirmation.

About 3 and the your strange feeling. No idea. I have the Hue Bridge, but without any rules / Scenes. Also the strange behaviour if I overrule my flow with Alexa that the lights are dimmed again. Very strange, if you say this should not happen. I will investigate.

Need some time to play around and test. Thanks a lot for your great help. Really appreciate that you take your time to support me. Will get back to you after testing.

1 Like

Are the lamps connected via another bridge like Philips Hue? Could it be that that bridge has rules set?

Thanks for your help and idea, Yes, I have the Hue Bridge. But I have checked and disabled / deleted all routines there. Also no formulas in my labs in Hue. And there is no other brigde / gateway in my home. Only Hue and Homey. I will now disable flows and test from there the behavior.

I have attached the flow which dims the hallway lamp. If I tell Alexa to turn Hallway lamp to 100% (since I need the light), then the flow dims it back to 30%. This is one of the issues I have.

Any Idea :slight_smile: ?

Ur logic card in the AND colom is not complete?
And u say WHEN brightness changes THEN change dim level?
So the motion sensor catches the light , change brightness and turn the bulb down?

thanks for your help. Yes, I am not sure if my card is logic. My idea is that the motion sensor catches the light, the lux must be below 30 lx (so only when it is dark), me or my wife needs to be at home and the lamp should be switched on only when our little one goes to bed (between 1900 - 2145).

Why do you think the AND logic is not complete. I am not sure what I am missing :roll_eyes:. Do you have an idea what I do wrong or what is the smarter way to achieve that? Thanks for your help.

Because there is a question mark.
There u should choose a value or tag.


strange. in my flow there is “Brightness” (Helligkeit), which I have picked from the motion sensor.

When I post the flow, the tag is missing and a ? appears.

Very strange. However, the flow only runs when the lux is below 30. At least that works. Would you write the flow completely differently to reach what I want? Or os the logic itself ok?

I would.
The brightness is changing when the light turns to 100%. The brightness will stay below 30 so the flow will turn the bulb back to 30%.
Whenever the brightness is changing AND is below 30 the light will go to 30%.
Something u can do is add “disable flow” to the THEN part and enable the flow (with another flow) at 2200 hours. When u tell Alexa to turn to 100% u also have to tell her to turn back to 30% later.
But i would pick another trigger. I would not want the hallway light to be on all the time, only when there is motion. But that’s personal.

Thanks a lot. Good point. I will play around with the brightness. And disabling the flow after might be the easiest way. Since you are right. It might be tricky to find a logic to let the system know to go back to the dimmed state after I told Alexa to increase the light to 100%.

Regarding the movement in my hallways this is not an option, since the hallway is connected to the living room and should not go on an off all the time. It is dimmed to have light there, but not a lot. Just to have enough to go towards the bedrooms. But thanks for the idea.

In general. Is there a good area in the community where these basic issues are explained in a blog post or video. All light flows are a type of mix of the three sensors movement, brightness and home/away. At least this is what I found out.

I appreciate your help a lot. Thank you very much for your ideas.

Hi @Ringler,
I am using sensor to determinate when to turn on lights too.
But I am not accessing their values directly. I have separate flows which update logic variables with the measured light value. But in the AND condition of those flows I check if the light is on.
This prevents the sensors from reading the value into the variable if the light is turned on.
Effectively my lights know when it is dark but do not start considering turned on lights as it getting brighter.

This sounds smart. But I have no clue how to create these logics. Can I find an example. I thought I can keep it simple, but you are right, the light affects the brightness in a way. However, it did not lead to too much on an off, except of the hallway probably. But I will check the behavior later tonite. The dimmed lights are not creating real Lux, so prob. No a big influence.

Do you have an example of the two flows you use (set a Varanasi in one flow and use this in another)

Thanks for your effort and help!

You can create logic variables in Homey app Menu “More…” -> “Logic”
And the just search for logic flowcards. It’s no rocket science really :smiley: