Horstman SRT321 is only recognized as a Basic Z-Wave device

SRT321 is listed in the read me in App Store as available device. After when it has been installed SRT321 is not recognized and stated as Basic Z-Wave device.
During the installation it is retrieving command class versions etc. I have tried include and exclude several times and even holding the SRT321 very close …
Any advice how to do proper installation?
Please see the screenshot


Have you actually installed this Horstman App?
This App is v0.1.4 - 14.11.17 so probably not compatible with Homey V2

I am still on Firmware Version: 1.5.13 …

That an app is update in 2017, doesn’t mean that the app is not compatible with Homey SW v2.0.

Only apps that have an app settings page, are known to have issues with 2.0.

Almost all Z-wave apps run fine with 2.0, with only minor cosmetically changes required.

1 Like

But the question is why it is only recognized as a Basic Z-wave. My Homey is new, I have no many devices installed yet - moving everything from Fibaro … SRT321 is new means never installed before …

Nevertheless try to EXCLUDE the device and then try to include again

Thank you for helping me but I have tried include and exclude several times and even holding the SRT321 very close … Nothing helps, even restarted Homey …

What are the ID’s shown in the device information when the device is added as generic Z-wave device?

NodeID 41

The SRT321 in the app is defined with a productID of 3, while your device is reporting 5. That explains the inability to find a match during inclusion.

You’ll have to contact the developer to ask for an app update.

You could also try to download the app, manually change the productID in the app.json to 5 and install that app through the CLI to your Homey.

OK, thank you :slight_smile: but my knowledge how to change in the app.json and how to install through the CLI is like null right now …
I will contact developer

You have not contacted me yet :stuck_out_tongue:
Is therestill need for this? If so, I might be able to have some time to update this in about 10 days (sorry, I am in germany for work untill then)

Hi, thank you!
I have contacted you via Github contact form.
Anyway I’ll be very pleased if you can help :slight_smile:

Somehow I do not get notifications from github anymore.
I updated the app. Let me know if things are workgin for you now. (app will probably be available in the appstore tomorrow)

Thank you!

@toox does this mean it works for you now?

Thank you for updating the application, but to tell you the truth since I was not sure about the device, I have returned it to the shop.

Skickat från min iPhone X