HomeySetup-XXXX asks password in first time setup

Hi, I want to setup my brand new Homey. It was connected once, but since then it starts in the ‘welcome to homey’ setup mode. I can see the wifi SSID HomeySetup-XXXX, but unable to connect. Tried iPhone, Macbook, Android. On IOS it asks a WiFi password.
I tried to reset Homey holding it upside down, but no counter is heard. Ring stays yellow
Any idea’s?

Try holding it upside-down and then put the powerplug in. After 10 seconds homey starts talking About recovery.

Tnx Joel!
Unfortunately Homey also goes to the setup mode while started upside-down. Probably has not loaded the software yet to understand this

Maybe the powerplug gives this problem, already tried an other powerplug? Min 2 AMP.

Tried the orignal one, another one, a macbook, power bank. So no power issue. I will have the Homey RMA’d. Looks stuck in a boot process


If the WiFi SSID for the 5ghz network is the same as for the 2.4 Ghz network try disabling the 5 Ghz network and try again. Also, mage sure DNS to and isn’t blocked.

Tnx guys for thinking with me. I swapped my Homey for another one today, and I am already busy adding devices and creating flows.
Looks like the first Homey was stuck in it’s boot proces

great to hear! have some fun tonight!:stuck_out_tongue_winking_eye: