Homeyscript server problem

I have made a script to get the performance of my solar panels. It retrieves the data of my solaredge inverter and some better logic variables.

The problem which occurs quite often when i am using Homeyscrip I sometimes get an error that the server is not available. Solution: Log in again, problem solved…But

I run a flow to activate my script, the problem is that in case Homeyscript is not available I will get “old” data. When i login again in Homeyscript the problem will be solved, but that’s not an option for the flow.

Is there a real solution? Anyone has the same problems?

It’s unclear to me which parts are being referred to here: is the “server” the Homeyscript website, or the Solaredge inverter? And logging in where fixes the problem?

quote=“robertklep, post:3, topic:14273, full:true”]
I usually get “Homey offline” when I try to open the HomeyScript website, logging out and back in again solves that for me.

This is what I mean, used your solution to solve it. But for running a script this is a problem.

In that case, I don’t think there’s a real solution. Networking issues have plagued Homey ever since firmware v2 was released, and because they seem to be intermittent Athom has never been able to fix them (and because Homey is a black box to us outsiders, we can’t debug these issues either).

Ok, i was afraid for this. I will try another approach, maybe I can work around this problem. Just maybe the Influxdb could be a solution. But at this point I have influxdb running, but have no idea how to retrieve the data e.g how to get the data of my inverter into my script. This is what intended to in a later fase of my script.

You’d have to implement an (minimal) InfluxDB API client using fetch

1 Like

Thx pointing me in the right direction