Homeydash.com, a Homey dashboard

Sorry…didn’t read properly. Webview isn’t really good for anything and I don’t think it supports a lot of js, so if you can use it with another browser I’d go for that.

I understand but I use Kiosk Browser Lockdown so that only that webpage is always displayed when you activate the tablet and you cannot go out of it.

When using a normal browser you cannot lock it so that is no option. The way I understand Kiosk Browser Lockdown uses the webview to display the webpage and up till now all the different dashboards I used worked fine including the original webview of Homey Ink but not the Homeydash one.

1 Like

BTW: Just for fun, I tried again in Firefox. Seems it opens the correct page for just a millisec before redirecting to the “please log-in” screen again. Same for chrome in incognito mode.

EDIT: Yeah, I tried logging in again. A few times. Didn’t stick.

Old devices like <ios 10 are not supported. So I guess android also…

But windows 10 should work :wink:

Awesome work guys!

Used both the hosted version and the self hosted version on my 2016 server both work a treat!!


1 Like

This url has &token=&token=eyJ...that will most definitely not work. When the correct page is shown for a millisec and gets redirected to the “please log-in” screen the token is not accepted.

-But did you logout and login before trying again like @Rocodamelshekima advised? Because i see the same token in both screenshots…

Never mind, see reaction from @DaneedeKruyff after mine.

You don’t get a new token when you log out and back in again. The token will only change when the password of your account is changed. The problem in that particular case is the double token= in the url as I posted.


The dashboard is updated to version 1.0.3

These are the changes

  • web theme is loaded when theme= is omitted
  • Added presence indication for UniFi devices

Small changes this time, thanks to @Andre_Prins for helping testing the presence indication for UniFi devices!

1 Like

Thanks. That was the solution. Didn’t see that I had double “token=”.

Can’t seem to get it to work. Did all the steps mentions and paste token after “=” in url.
Keep getting message that token is invalid.

Help would be appreciated

After a successful logon at homey.ink click on the link in the console.
When the page is loaded replace app.homey.ink/?theme=kobo-h2o in de address bar with homeydash.com/?theme=web

Tying to load homeydash on Chrome in browser.

I did exactly this:

How to get the token:
Go to ‘https://homey.ink
Login at that page and after that open the console of your browser.
There you will find your token. Copy the token.
Then go to ‘https://homeydash.com/?theme=web&lang=en&token= ’ and fill in your token after that link.

What am i missing here? using chrome browser

And, just to be sure, can u try it the way I described a post above urs?

Looks like I can’t get a successful login. “token invalid”
Can’t see: “app.homey.ink/?theme=kobo-h2o” so can’t replace

Did you click the link in the console when you logged in at app.homey.ink?

Sorry to say that I don’t know exactly what you mean.
So the answer will be no (probably)

Got it now. Thanks