Homey Pro: fighting with Aqara Water sensor & Innr plugs


New to Homey and recently received my Homey Pro. Paired a few devices but struggling with 2 in particular: Aqara Water Sensor and INNR SP222 plugs.

  • The Aqara sensors just don’t work: I connect them, but they don’t sense water (or they don’t communicate anything back). Tried removing them, reconnecting, rebooting Homey… Nothing. I have 3 of them and they all exhibit the same issue. Any ideas?

  • INNR SP222 plugs: they work well for ON/OFF but I’m not getting any power readings from them (I’d like to use that for Automation). Anyone encountered this issue? Or is this model just not able to read this data?

Thanks in advance!

First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum post here.

INNR SP222 plug: According to the App Store, these plugs should be able to measure and report power data:

Is the INNR app installed and the plugs as SP222 recognised or just as a “Generic Zigbee Device”?

Aqara Water Sensor: Same questions, App installed, recognized as Aqara WS or as “Generic Zigbee Device”?
Never read from such problem. Maybe check out the corresponding topic about the Aqara App and devices:

Thanks for the quick reply. Just checked and both the INNR plugs and Aqara water sensors are recognised properly (and app installed etc.).

I’ve noticed that the INNR plugs are all set as “End Devices” rather than routers. Probablly doesn’t help the Zigbee network.

Any idea how I can change this?

I have read about this before and of course it shouldn’t be like this.
I think the only way is to contact INNR (developer of the app) and/or Athom support.

Happened to me also with IKEA Tradfri, when I remove them and add again, they were added then correctly. But reading it’s not just me, I would highly recommend to contact Athom and prior fixing it, to provide them with diag. logs (if you attempted already and it’s still the case, then for sure Athom)

Indeed fixed after removing / adding. Saw your message too late so no log to share to Homey…

Now I need to fix the Aqara devices as they keep not reporting. Or do it for a while and then just stop. Found another post with someone having long standing issues with Aqara and Homey. Hoping it’s not my case as well…

This is a rather well known issue with the combination of Aqara + Homey + Osram/Ledvance / Ikea Tradfri lights + Homey 201x white balls;
Not sure if it’s still the case @ Pro 2023…
As soon as an Aqara sensor starts to use an Ikea light as router, it just stops reporting.
I changed my Ikea for Lidl lights, and Aqara’s work reliable again.

If Innr causes the same issues, idk. What I know is, Innr is not very stable with Homey, so that doesn’t help concerning combining it with Aqara.

Here’s a very detailed post about ins and outs of Aqara / Xiaomi sensors combined with other brands/devices (it has not specifically to do with Hubitat here):

1 Like

Ou, didn’t know about that limitation and recently just recommended HP23 with this combination to a neighbor. Is that somewhere described as known issue or it’s based on community experience Peter ? I wonder if Athom knows as this is a bummer indeed.

Thanks Peter. I guess I should have researched more before buying. I’m sure I saw some Aqara devices in Homey marketing so that feels a bit hard to swallow…

I only have a few devices but all are either INNR or Aqara. Just 6 devices / sensors so I could replace all of them but it seems like throwing money out the window. Thanks for the Hubitat post I’ll explore it.

I have a similar issue, where I have quite some innr, tradfri and aqara devices. In my experience it’s the innr devices causing most of the issues. I’m currently replacing those with ones from blitzwolf (they can also manage a higher load).
Also make sure in general to:

  • First add all powered devices from nearest for farthest from homey
  • Repeat in the same order for end devices (I remember reading that xiaomi devices don’t like to switch the router their linked to?)
  • add the devices in the location you want to use them

Reading all those comments, has any of you actually tried to upgrade IKEA,innr firmware, eg. via Zigbee2MQTT ? Might be also another way to resolve it unless it’s broken on Homey side…

Eg. check if your INNR devices does support OTA / | Zigbee2MQTT or IKEA - | Zigbee2MQTT

Removed INNR plugs and now the Aqara sensors seem to work OK…I’ll give it a few hours to retest.

I’m new to smart homes so never heard of Zigbee2MQTT. Would you install that on Homey Pro and just use it as a way to update firmware? I did find the plugs I have (Innr SP 222 control via MQTT | Zigbee2MQTT) but I’m not sure how to check for any available FW updates.

No,that requires laptop/ RPI with Zigbee2Mqtt installed amd USB Zigbee dongle … it’s not expensive but requires some technical knowledge. True is that you should not require anything like this, that’s why you purchased Homey, right…

Sorry, I wasn’t specific enough, it was the case here with my Pro 2019, but after reading so many issues with Aqara + Pro 2023, it seems to be the same issue again.
(Aqara + Ikea work just fine with zigbee2mqtt by the way)


No never, but that’s personal (why would one need to update a f… lightbulb…) Ofcourse it’s a different story when Matter f.i. becomes available through fw updates.

But, in my humble opinion the issue is not with Ikea, Ledvance Osram and such, it’s Aqara not following standards.

1 Like