Homey Backup and Restore - Homey Migration

I think i already know the answer, but is It possible to restore single flows and other stuff , or only complete restore via recovery?

No, See the Homey Cloud Backup vs HCB&RWA
But I can with HCB&RWA :wink:

My backup fails with a ‘cannot create backup. Backups are limited to 3 unique Homeys’ message. I haven’t managed to create even 1 yet. There are more than 3 Homeys on my account but I see no way to select which ones you want to backup. Except possibly by disabling automatic backups.

Reported to Athom.

1 Like

Got 100 messages that I got rate limited.
Haven’t started any backup manually…

Finally, a backup option. Payed, ok, not ideal but I can live with that.

I payed for Homey+ but see no options for backup. I am not an alpha tester so it may be that I do not see the option. Has this been released for non-alpha testers?

as stated in Homey Cloud Backup - (part of Homey+ subscription) from Homey Version 4.0 and up, currently in Experimental.

If you are on 3.2.1 and got Homey+ please loot at Help Homey+ backup met Homey <4.0 software

4.0 has been promoted to stable today


Hi @Rocodamelshekima,
Expected that you would test that yourself :wink:

I Was waiting for your results to add it to my post.

O, and Yes I alread did several times :wink:

I still can’t backup. I get the message limited to 3 unique Homeys. I haven’t managed a single backup yet. My account has more than 3 Homeys … I suspect this is the issue.

I don’t know why I ever bother with beta feedback when it’s just ignored.

Got Homey backup installed on my new Homey Pro.
However, all Zigbee related is not working. Still searching.
Also in the Add devices page, I cannot click on a device to Re-enter a device.
these icons also keep rotating.
Any help?
All flows, apps, z-wave, settings etc are installed correctly.

Have you Checked https://developer.athom.com/tools/zigbee .? Are all devices there like before?
Always give Homey ~ 15 minutes after reboot to start Zigbee, if it doesn’t work then PtP for a couple of minutes and try again.

Same after PTP, waiting 5 mins, plug in again and reboot wait 25 mins.
Same screen in developer.
Looks like zigbee is not activated? No system information…


Upgraded from Homey to Homey Pro yesterday when 4.0.0 stable came out. I have to say, it was a pretty good process. All of my Fibaro and NEO Coolcam Z-wave devices where migrated, also for Shelly devices no problems. For Zigbee, my Heiman and most of my Aqara devices migrated. Some of my Aqara sensors did not seem to react anymore, but after un/replugging an IKEA plug (that was acting as a repeater earlier) that also was not responding, the mesh got restored (I guess) and most of them reconnected. I only had to exclude/include two devices: one Aqara motion sensor, and one Aqara Temperature sensor.

All in all I am very happy to have been able to upgrade this “seamless”


Hi Dijker,
Tried to roll back yesterday several times, did not work all zigbee give same error (circle keep on turning.) Rest is working.
I m afraid I’ll have to do clean install.
Tried to install different backups, but no luck… The wife is getting a bit nervous since we can only turn on certain things with app only… :grin:

Hi, same here, going from Homey to Homey Pro. Everything works fine, except all my IKEA Trådfri, zigbee devices. They show up on the developer ZigBee page, but when trying to control a device, an error message is shown in the app after a few seconds. Tried power cycling the devices and Homey, but no luck.

1 Like

Can you try to add a already added device again, without removing it.
I guess when you get the duplicate device error it will start working again maybe even the other devices… fe a IKEA tradfri socket or repeater is the easiest as it has a reset hole.

It should not be necessary to fix flows that way.

Thanks, it worked again when adding the already existing device.

Just upgraded to homey Pro. Have to say that the recovery went extremely smooth for all my devices and all apps except for 1; IFTTT loses the flow connections and you need to rename the flows and applets in homey to connect again (same names do not update)

Well done on this one Athom, works like a charm!!