Home Energy Dashboad showing Solarpanel but adds as consumption


i have the solar panels connected and they are shown in the right category. Nevertheless the total energy consumed is not the delta between solar production and house consumption. It simply add it all up. It once worked showing solar as the outer ring, and in the middle only the consumers.

Any ideas?


Your solar panels are showing a negative value, so that becomes: total = 222 - -225 = 579.
The solar energy should be positive:

Hello Adrian,

My solarpanels are giving a positive value. But the app doesnt see them as solarpanels, but adds the value as a user. Do you haven any idea how i can get this info in the outer ring? It adds the energy in the inner ring.

best regards,

Is the device defined with “class”: “solarpanel”?

This is my current energy page:

But in the picture you posted, your solar panel value is -225 W, so the ring will be empty.

I did not send a screenshot yet but hereby I will

Sorry, I got mixed up with the first post as i didn’t notice the different name.
Your panels are not showing up as solar panels, so I guess the device class is wrong in the app.

What app are you using to add the panels?

Homewizard app

i use the Fritzbox app.

This is the setting in Homey as solarpanel


i heard and once saw, that the outer ring of the visual is for energy input. and this doesnt happen. the solar panels are part of the pie chart like any other devices

OK, so you will need to let the Fritzbox developer know that solar panels should show a positive value for the output for that to work.

It took me a long time of playing around to get my app to show the correct information :slight_smile:

I can’t say for sure but it looks like the device class is probably set to be a sensor. You will need to contact the Homewizard app developer and ask if they can provide a ‘solarpanel’ class device.

I think my Sofar app is setup correctly as I see all the right information in the right places, so if anyone wants to take a look it’s in my GitHub repo GitHub - AdyRock/ady.sofar

Its already there in dutch aangesloten zonnepaneel is device solarpanek

Can you got to the developer portal and log in to your account, then select the Devices section (Homey Developer Tools). Find you solar panel device in the list and check the Class

Hello Adrian,

Never been on this page. But it was easy to find with google. Found the device and it says class: Socket (virtual: Solarpanel). So maybe it thinks its still a socket?
Can i change this anywhere?

Best regards,

It will need to be changed by the app developer.

oh i did it. the avm lets you select solar panels im two ways