Help on how to create flow

so it’s a bit complicated
i hope u understand me :smiley:

i have motion sensor
i want to set a flow:

if this time is between 07:00 and10:00
set logic to
i am up

but i want it to work only once and not evry time the sensor will sense a motion between the hours…how do i do it ?

Set following flows

motion is detected

time is between 7.00-10.00 and
logic variable “happened today” is false

set logic variable “I am awake” true
set logic variable “happened today” true

Flow 2
Every 1d

Set logic variable “happened today” false

WHEN motion is detected
AND time is between 7 and 10
THEN set logic to true AND disable this flow

WHEN time is 7
THEN enable first flow

(Please keep in mind that there’s a difference between enabling a flow and starting a flow!)

Im sorry but i am not sure i understand.
How do i do flow:
Every 1d

How do i do it?
And y do i need both i am a wake and heppend today ? Y not just 1?

@peltsi51 used ‘happened today’ to prevent the flow from running twice.

@Rocodamelshekima used disabling and enabling the flow to accomplish the same goal.

It’s up to you to decide which one you prefer.

so lets say i disable the flow
how will i set it to be disable for XXX time…?
i mean lets say i did the flow wich disable the first flew so it will not reapet itself…how do i set it to start working again?

im hope u can understand me…my english is…comsi comsa :smiley:

i try to do as u say
i added pic of first flow
is it correct?

ok so this is what i did
is it correct?
im still not sure how it will not repet itself again lets say at 7:15 and in 7:30 and so on…
really apriciate if u can help me and offcurse thankyou for all ur help so far :smiley:

`no` (which you are using in the first flow) is not the same as No (which you are using in the second flow).

You also have to add in the then part of second flow that you set the “Im up” into no. I forgot that from the previous post.

What do u mean? Where did i go wrong?

You are setting the value of the variable to “No” (uppercase N, lowercase o) in the second flow, but in the first flow you are comparing its value against “backtick-lowercase n-lowercase o-backtick”. That comparison will always fail, both the value and the comparison need to be exactly the same.

I cant control if it is capital No or no…

And you also can’t change the “is equal to” value?

Hi @Oren_Malki!

I have a similar solution for this. When you click on your profile in Homey you can see “wake-up” or not. My setting for this is if its daytime and I’m home (based on GPS) and I open the IKEA smart blinds between 8 AM and 12 AM - then I’m awake and the morning flow starts with the coffee machine, TV, music etc.

At night if the time is between 6PM - 11 PM, I’m home (based on GPS) and the TV is off (which is always on usually) then Homey knows its nighttime and I’m asleep.

i can make it equl to… but equl to what?

Ah never mind, you used the inverted is equal to "yes" card. I don’t understand why that wouldn’t work…