Heimdall - Let Homey watch over your home

Dear @DaneedeKruyff you are absolutely right. A bit wired translation of the Flow names (arming and inserting into Italian are almost the same) made me making the mistake.

Now that I changed the flow card everything seem working smoothly.
Thanks again.

Glad you have it working as you desire.

Any tips on improving the translations are welcome, just let me know what you think can be made better.

And thank you for your donation, much appreciated!

1 Like

Is it possible to add Polish language? I can make translation :slight_smile:

Sure, but realise yourself it will be a lot of work.

I’ll send you a PM.

strange issue on hp2023…when it reboots after upgrading only Heimdall needs to be manually restarted othrrwise is not correctly loaded…

Could be your homey is to busy during restart, result of the under clocking by a lack of power, but this shouldn’t happen and I haven’t seen this before. (But there a still a lot of random errors thrown due to underpowered Homeys)

When this happens next time, please send me a diagnostics report before you restart Heimdall.

ok…i’ll try in the afternoon…

Inviato dal mio Galaxy

-------- Messaggio originale --------

i tried to reboot several times with 5.3V stable power supply and seems to be ok.
the strange thing is that i have a lot of devices (shellys, zigbee, zwave, HA integrations, netatmo… ) then a lot of apps and only heimdall suffered for this. i’ll let you know if it happens again. thanks.

Well, that’s not so strange, specific brand apps only rely on themselves to be stable and the technologie they use e.g Zigbee or Z-Wave etc. Heimdall relies on all others apps and Homey itself to be fully started and stable. Heimdall takes this into account when starting but sometimes strange things still happen, also not forget the firmware is still not released as stable.

this morning homey did autoupdate and on restart heimdall was off again

this is the diag report 5ae48507-2c46-4a36-90eb-4291de65b352

restarting heimdall resolve the issue

Thanks, for the log, unfortunately it shows no error for Heimdall just the starting sequence. Did you send this after restarting Heimdall?
I do notice 63 reports of devices not ready when Heimdall starts, Heimdall will continue and they will be added letter when (if) they become available so that shouldn’t be a problem.

The strange thing is, when you manually reboot there doesn’t seem to be a problem but after a firmware upgrade there is a problem. Could you please report that to Athom specifically mentioning that.

Also, when this happens, could you please go to https://tools.developer.homey.app/tools/system and check the videoCoreUndervoltageOccured and videoCoreUnderVoltageCurrently values?
Or install the Homey System Internals app [APP][Pro] sysInternals - Shows Homey’s System Internals and check that.

  1. No, i did send the report before restarting heimdall.
  2. Voltage is ok. I installed a regulator with constant 5.3V and all the flags in sys dev are false, then is not undervoltage problem.
  3. I will report this to athom for sure.
  4. For now, can i check via flow after reboot if heimdall is functional? Or auto restart the app if there is a problem?

Thanks a lot.

  1. Ok if it’s from before restarting then the app did not recieve any warnings from homey.
  2. Regarding the voltage, while you supply 5.3volt is doesn’t prove the cpu won’t register a voltage drop under load, please do check those values at the developers pages.
  3. Thanks, this is usefull information for Athom to improve the firmware and firmware update process.
  4. No, not that I know of.

5.3v is the minimum voltage if found (with a lot measurements) to ensure the right power with ethernet adapter

This is after normal reboot…


After restarting heimdall….



Thanks, That report also shows no indication what is going on, no error in it. The log looks normal, no app crash or warning from Homey itself towards the app so I have no idea where I should start to ‘fix’ this as nothing wrong is reported.
Even though I have no insight in the exact number of users using Heimdall on the Homey Pro Early 2023 there are quite some judging by error reports I receive on other quirks in the firmware, as far as I know this problem is limited to your Homey/situation so I have not much to go on.

What I did notice; you’re running version 10.0.0-rc.69 which is an experimental version of the Release Candidates. My first advice is to disable the Experimental Updates in the Developer Tools if you rely on this Homey for your home automation
Second advice is to disable automatic updates (for now) so you are in control when your Homey reboots after an update and can immediately take corrective action if Heimdall shows problems after a reboot/firmware install.

ok thanks.

New version published to test channel

Test version 2.10.11

  • Updated homey-api to 3.0.0-rc.18
  • Improved retrieving zone names

To keep up with the changes made by Athom to the homey-api I’ve updated the used version in Heimdall to the latest Release Candidate.
I’ve also made some improvements in the way the zone name of a device is read while it is no longer available as a property on a device and needs to be retrieved separately. Somehow the function to retrieve zone information is an expensive one on old Homeys, I received many errors from them. This change will hopefully solve that error.


New version published to test channel

Test version 2.10.12

  • Improved retrieving zone names

After the previous test version I still received some automatic error reports, but luckily a lot less. I’ve made another minor changes which I hope will improve retrieving the zone names even more.


Test version promoted to stable

Test version 2.10.12

  • Improved retrieving zone names

In the version the retrieval of the zone name in which a device is placed is further improved.