Heating control Fibaro motion sensor

I want to control a Kasa plug to switch on my central heating pump when my Fibaro motion sensor gets below a certain temperature during certain times of the day. I have done the flow to turn on the plug at certain times when temperature is below a certain figure but it does not work! As my ideas?

Pls. share your flow to be able to find out if there is a possible error in the flow.

Does this share it?


The problem with this flow is the trigger card: Temperature becomes less than 22 °C
If the temperature becomes less than 22 °C e.g. at 5:55 o’clock, the flow will not be executed, because the timeframe (6 - 9 o’clock) isn’t fulfilled. And if the temperature does not rise above 22 °C again within this timeframe and falls below 22 °C again within this timeframe, then the flow is not executed, so the plug is not switched on:
According your flow, the temperature must drop from greater than 22 °C to less than 22 °C within the timeframe 6 - 9 o’clock.

Please change it like this:


– The temperature changed
– Temperature ist less than 22
– The time is between 06:00 and 09:00
– Turn on

Any temperature change triggers the flow. If the temperature change is below 22 °C (e.g. from 21.5 to 21.2 °C) and the time is between 6 and 9 o’clock, the flow is executed.
It does not matter if the temperature was already below 22 °C before 6 o’clock.

Hi thanks for the support so far.
When I select when the temperature has changed and I select and it does not give me an option to select if temp goes below? See screenshot?
How do I also set the flow to turn off when temp goes above 22?


I have sorted it now thanks I had to alter advanced setting on Fibaro thermostat and logic for the temp change

In principle, no settings need to be changed on the Fibaro Motion Sensor, unless you want the temperature data to be sent to Homey more frequently.

Have you managed to create a flow when the temperature rises above 22 °C again?
If not, please tell me the conditions for this flow.

The temperature was set to change at 1 deg change

This is my flow for off

Ok, a reporting threshold of 1 °C with a range of 2 °C is of course too little.

Your flow will not work. It can’t be between 6:00 and 8:30 and after 9:00 at the same time.
I don’t know your exact requirements/conditions now, but the flow could look like this:

If you need a translation, please let me know.