Google text to speech (tts)

Good morning all,

Since two days, my flows with Google text to speech don’t work anymore. When I do the test, it says it’s done, but I don’t hear anything. I tried it on different flows and on different devices (Google home mini, 2 Google home nest minis)
The google home mini and next mini work perfectly for everything else.

Do this an error in the app? Will it be updated or is it just me having this problem? Any solutions?

Nevermind, while writing this, I came to the idea to restart the app. It works fine now. Sorry!

1 Like

Google TTS crashes often, as a workaround I made a flow to restart it. Works perfectly

1 Like

@G.P_Bruins Thank you so much. That’s helpfull! Does homey always know when it’s crashed?

And I sadly can’t find the card to make this flow. Where can I find it?

@G.P_Bruins I’m either blind or…

Ur not blind but u need to enable power user in “Experiments”

1 Like

Thanks! I keep learning.
Btw, I remember you from before. Thanks so much for helping the community!

1 Like


Unfortunately my Google TTS can’t find my devices anymore. Broadcast to all doesn’t work either. Restarting does nothing.

Did you try to shut down the device power for a while for a big reset?

1 Like

That solved it. Thank you.

1 Like

I have made a Speaker group in Google Home, and i can select this in Homey with this App.
I have 3 Google Home Speakers in this group, but when i want to speak with all speakers in the Group only one speaker is used.
Is this normal, or a bug

I restarted the app, homey and resynced devices etc but I just can’t get it to say out loud the phrase which I put into the app to say. I can hear how my Google Home Max changes volume but it never gets anything said. It did however work on my Android TV when I chose it as output device. But the TV is not in the right area where I want my memos to be played :confused:

Am I the only one who has this problem? I got two Google Home Max connected as a speaker pair and a Homey Pro.

I have the exact same problem since at least two weeks. Restarting app, Homey, re-syncing or creating a new flow does not resolve it.

Ok fixed it. Removed the connected homey account from google home. And connected it again. This didn’t solve it but I noticed that both the chromecast and the Google hone mini had the exact same device names in the account… after a namechange and assigning the speaker again it suddenly worked. Pretty weird since it has been working for over a year I wonder why all devices had the same name assigned.

So check the devices names in the google home app. Edit them (if they are the same) and resync the google connection in the homey app. Then check the flows

What’s new in v1.4.2

Fix setting volume with a tag

Great solution. Unfortunately, all the existing volume settings in the flows are reset to 0% or 1%, by updating to this version!
@Dennie de Groot

Edit: Be aware, a value of 0,4 does not work, but a value of 40 does work fine.

Hey, I have a few question:
Is it possible to remove the chime right before TTS? I assume it’s a sound when a device connects to a speaker.
And is there any way to emulate a voice command? For example - I have a nvidia shield connected to my projector, and when I turn it on, it starts the shied, then starts my projector via hdmi cec and my projector screen gets deployed. Unfortunately there is ni button to turn on the shield in honeys or google home UIs, so I always have to say “ok google, turn on shield”. Any ideas?