FIBARO Walli roller shutter - change of configuration parameters by raw command

Hello guys!

I am trying to set my venetian blinds to auto mode during hot summer days - tilt them based on the altitute and azimuth such a way the direct sun beams are blocked but the slats are on maximal opening angle to allow dispersed light in. I successfully made a flow that sets the angle of slats.

The problem I am having is related to the Blind type (parameter 151). If the blind type is set to 1 (roller blinds), the slats are not able to tilt by app / flow (its possible by holding the walli roller shutter button physically). But if I set the parameter to 2 (venetian blinds) the tilting is possible by app / flow, but the slats when fully open does not hide inside the designated box and stay about 10cm below. I noticed that this is caused due to the fact the top slat is always oriented top-down and not folded with the others. The app also shows that when requested to be 100% open is actually something like 97% open and it cannot be forced to 100%. The motor first fully open the blind, stops, wait and then move down a bit to make the top slat oriented top-down. Dunno why.

I need to either solve the issue with the top slat (but that seems really not realistic option) or to make a flow that basically flip the blind type between roller and venetian blinds when the auto mode flow is activated or deactivated. The rest of the time (when not in auto mode) it may be set (parameter 151) as roller blind and hide into the designated box completely as intended. So I wanted to basically just make a flow with a raw command: set the blind type to venetian blinds and another one with set the blind type to roller blind.

The raw command flow does not work though. I am able to change other things (like led ring brightness) by the raw commands, but not the parameter 151.

The raw command syntax I use is 0x70,0x04,0x97,0x01,0x01 (roller blinds) and 0x70,0x04,0x97,0x01,0x02. In other words: command_class_configuration, set, parameter 151, 1byte, value 1/2.

Am I missing something? Why it may not work? Maybe parameter 151 is not adjustable by this command class and I need to use other? I also tried command_class_basic but with no avail.


1 Like

Hi Tomas,

I also have the Fibaro Walli Roller Shutter in place with some venetian blinds - and I also have some troubles with the tilt position. For my blinds I always have to set the tilt position to 100% when I close my blinds - then they “hide” as they are desired to do so…

But unfortunately, they always remember the last tilt position that has been set by the app - so when I open the blinds and try to set tilt orientation by the walli switch, after a few seconds the last “stored” tilt-position (100%) is set again automatically. - That means - as far as I understand it correctly - that setting the tilt orientation by switch is no more possible after I have set the tilt-level once by app…

In the parameters (151) the blind type is set to “venetian blind mode, with positioning”.

Maybe we may find a solution together…

Kind regards,

… after writing my lines above I also had a look to the manual ( and observed a parameter 153 “Set slats back to previous position” - maybe this could be a solution for the problem. But this parameter isn’t available in the settings of the app/device…

Hello Seiti,

thank you for your answer! I tried the 153 parameter in Raw Configuration Parameters: 153,1,0 and all seems to be all right now, the blinds hide behind the designated box property. Seems it was easy after all. Will see how this will work when the blinds will be used extensively.

Thanks again!

oh I’m happy to read that this really was the solution - I hope that it is still working!
Which text did you type in the raw configuration value field - just “153,1,0”?
(I’m still new to the world of Z-Wave :slight_smile: )

That is correct, 153,1,0. And so far so good! But we are not using them now much, that is more a summer shading tool. In the winter we use them just during some very nice and sunny days when the light rays prevents comfortable watching tv.

1 Like

Thank you!

Please use the Fibaro main topic for problems with Fibaro devices or the Homey Fibaro app:
[APP] Fibaro - Your home is your castle (by Athom)

For this reason this topic has been closed.