Fibaro UBS - Input triggers multiple times instead of once

I’m using a Fibaro Universal Binary Sensor to make my regular doorbell Z-wave compatible using the scheme below.

My only problem is that when the doorbell is pressed the flow is triggered about 10 times instead of just once. I can’t figure out why this is happening and can’t seem to fix it either…

My flow looks like this:

My Sensor is setup like this:

I’ve tried using Parameter 2 to delay repeated inputs for a few seconds but this doesn’t seem to work. How I’ve tried this is by inputing 2,2,2 in the raw parameters for a 2 second delay. This doesn’t seem to do anything.

The only workaround so far is used in the flow above, disabling the flow and then reenabling it after 5 seconds. This gives me 2 inputs instead of one which is workable for now but still doesn’t make any sense…

Can anyone point me in the right direction to fix this?


Why Opened, seems to me that it should be Closed ?
and why the relay?

I’ve tried Closed and Open Both give the same result. The relay is used to trigger the analog doorbell to give the person outside some kind of feedback

And the push button (doorbell) is that a old one? try to clean the contacts. They could be dirty and thefor making a bad connection wich could result in on off on off.

I bought a already bought new pusher and cleaned the contacts. The only thing i could donis pull new wire…

And what happends when you contect the 2 point on the fibaro together. If you then also get multiple messeges then you know it isnt the wire or the push button.

I already pointed out this problem. My two Fibaro UBS and also a new Fibaro Smart Implant both have the same issue: double or worse multiple notification. It is not a contact problem for sure as my 3 devices are connected to 3 different contacts, two relais and a door push button but all 3 have the same problem. One of the relais also drives a forth UBS connected to a Vera hub and this one has no issue. I do believe is a Fibaro app problem. At present I did a workaround using a VD and addressing to it the state of the UBS …this solves the problem but it remains a workaround.

So the You have a flow that makes the VD mirror the state of the UBS? Then you use the VD as a teigger for the intended use?

If that works that means the problem lies in the Fibaro App kn the Homey right?

Can anyone at Athom help with this issue?

Exactly. I did that way. All others workaround I tested were useless.
We should write directly to Homey guys …

@Rocco once you have tested the VD please just confirm here.

For test, you also can try to remove temporarily the relay part, maybe it’s influencing the UBS or its Power, testing al functions separate, can give you an idea of what part is the problem.