Fibaro Button - No difference in between the number of clicks

Kindly I ask someone with a Fibaro button running Homey v2 and Fibaro app latest beta 2.1.15, to confirm that the button works as it suppose to work.

Here is my problem: I own two Fibaro buttons and now both do not make the difference in between the number of clicks.
I create three flows,
Flow 1: WHEN 1x click THEN toggle light 1 on/off
Flow 2 WHEN 2x click THEN toggle light 2 on/off
Flow 3 WHEN 5x click THEN send a push message to my mobile phone.

Regardless I press the button 1x, 2x, 3x, 4x, 5x, hold and release, all the above flows are executed at once. It is like the button send commands for all type of clicks in the same time.

I created an issue to Athom, I did send them a log and the dev came back that my button(s) are faulty. It could be, although hard to believe that both in the same time decided to die.
Hence, before I jump to Athom’s throat, I would like to hear from you if same problem.
Please, note the above firmware and app version before responding. Thanks!!

Hey Danone, perhaps you could ask : @MasterAeon, @Olof_Filmstrom @Altar or @Marc_Berendsen ? Or Perhaps I just did by tagging them :face_with_raised_eyebrow:

1 Like

I’ll go and see tomorrow a friend with an HC2, include my both buttons and test them. Regardless of the result, I will get from him a brand new Fibaro sensor and test it with my system.

I would love to hear from others with same setup described above.

I have not upgraded to the 2.0 version yet. However I don’t think the problem relates to hardware faults. Definitively not when you got two of them. My problem with my Fibaro button is that it sends the different presses correctly (it can be seen in the developer Z-Wave log), but Homey doesn’t do anything with it. I have an open case with support where they acnowledge it as a problem in Homey.

They haven´t followed up the case since 6. december though, so customer services at Athom would definively not be rated as the quickest in the business regardless of a company doing a major upgrade or not. More manpower is just needed.

I would check the Z-Wave log to verify what commands Homey receives when you press the button x times. That is easy to trace. This is an example from my logs where I clicked once on the Fibaro button named internally as “Node[38]”. Look for the “Key Pressed x time” text for your spesific node:

[2018-12-01T14:46:29.064Z] Node[38]: Received application command for
[2018-12-01T14:46:29.064Z] Node[38]: [COMMAND_CLASS_SECURITY] {}
[2018-12-01T14:46:29.064Z] Node[38]: [COMMAND_CLASS_SECURITY]
[2018-12-01T14:46:29.065Z] Node[38]: sendData to COMMAND_CLASS_SECURITY,
params 0x8062003798bd07ccab
[2018-12-01T14:46:29.069Z] Command[223] start: sendData
[2018-12-01T14:46:29.070Z] ProcessSendData[209]: To node: 38 with data:
0x988062003798bd07ccab and txOptions: AUTO_ROUTE,EXPLORE
[2018-12-01T14:46:29.093Z] Command[223] end: sendData
[2018-12-01T14:46:29.115Z] Node[38]: Received application command for
[2018-12-01T14:46:29.116Z] Node[38]: [COMMAND_CLASS_SECURITY]
{“Initialization Vector
Counter”:1,“Sequenced”:false,“Second Frame”:false},“Command
byte”:{“type”:“Buffer”,“data”:[0,90,185,117,45]},“Receivers nonce
Identifier (Raw)”:{“type”:“Buffer”,“data”:[98]},“Receivers nonce
Identifier”:98,“Message Authentication Code
[2018-12-01T14:46:29.129Z] Node[38]: [COMMAND_CLASS_CENTRAL_SCENE]
{“Sequence Number (Raw)”:{“type”:“Buffer”,“data”:[12]},“Sequence
Refresh”:true,“Key Attributes”:“Key Pressed 1 time”},“Scene Number
(Raw)”:{“type”:“Buffer”,“data”:[1]},“Scene Number”:1}
[2018-12-01T14:46:29.129Z] Node[38]: Decapsulated frame from

1 Like

I have the same problem. If you get an answer /solution from them please share !

1 Like

Absolutely. Will do.

Great! I mean not great. But at least I am not alone with this problem.
PLEASE create an issue to Athom, in this way they will hopefully look into fix it!!

I have the same problem with the Button (dosen’t matter how man click)
Same result for me it happend with the new fibaro update 2.1.17 yesterday

@Bram ^^^

For the Fibaro Dimmer 2 I need to have “scene activation” enabled to trigger the 2x and 3x. Not sure if the Fibaro button also requires this…

Nope. The button only does scenes, nothing else.
Thank for the suggestion anyway. :grinning:

@MasterAeon @Tomlan66 @Ginfizz I was informed that this was fixed. It should come soon an update for us. Lets wait and hope for the best…

Ok, good news! Thanks @danone

Hi @MasterAeon @Tomlan66 @Ginfizz the app version 2.1.8 fixed the fibre button issue.
It works like it is supposed to work.
Family happy they can set again the house states.

Thank you very much to @Bram and all the Athom team involved for the fast communication and email exchange. I won’t forget that!

1 Like