Can't setup Fibaro Button on Homey 2023

Anyone managed to setup a Fibaro button on homey 2023…
Starts process but does not recognize the pairing clicks.

Just tried it, doesn’t work for me either. On HP19 it also doesn’t work for me. Have tried 2 batteries, but not sure if they are charged.

I changed and checked the battery, all good at 3.6V.
Ok so i will need to raise a ticket for this then.


Will do it also.

What comes into my mind. Are you sure you have the Z-Wave Button? Because there is also an Apple HomeKit Button available.

I ordered Z Wave and that is what it says was shipped i believe, and i am sure i saw Z Wave logo on bottom of button, but will double check when i get home.

Right, there must be the Z-Wave logo at the bottom.
In the meantime I checked also the batteries. One is dead, but the other is in good condition.

Restarting the app and the HP23 doesn’t solve this problem.

Tried that, and made sure the app was the latest version, also rebooted the Fibaro app.

Where is it we leave the tickets now for the HP23 version, they changed it didn’t they ?

Right. Because it’s not a HP23 issue, I opened a “normal” ticket incl. a diagnostic report no. of the Fibaro app:

App Store

My Homeys → Homey Pro 2023 → Apps → Fibaro → Contact Support

But I don’t know if it’s the right way… :man_shrugging:t3:

Have left a ticket also, lets see what the outcome is.

Did some further tests, and that is disappointing.

I tried to include the Button again and again at my Fibaro Home Center 2.
I also tried to reset the Button first and then it to include it again at the HC2.
All attempts failed…

Also I checked if the battery is inserted the right way around.

So I guess the Fibaro Button is a piece of junk just like their door/window sensor 2.

Have you ever included the Button before, e.g. at a HP19?
For me this was the first time adding the Button.

Check the contacts inside the button, not just the battery contacts themselves, but the internal contacts, they are very prone to stop making contact properly.

Tried it already with a screwdriver, but maybe not enough. So I will give it another chance.
Thx for the hint!

Don’t know exactly if this did the trick, but I was able to include it to the HP23.
However, I had to press the button very, very, very, very hard.

Summary: The button seems to be just as badly designed as the Door/Window Sensor 2.

Perhaps the worst piece of hardware produced by Fibaro.
Had 5 of them, all died one after the other with minimum use.
The inclusion into Homey was never easy either.
Would not recommend them.


Took a closer look at the button.
First I assumed that the problem is the contacts for the battery:

So I put two paper discs under the framework of the battery spring, so that the battery contact sticks out a little higher from the bottom part:

But this is not the problem.

The problem is the pushing of the microswitch:

The red top of the button must be pressed down extremely hard for the microswitch to switch. Then you can also hear a click. So I tried to bend the microswitch up a bit, but that didn’t work well.
Maybe it would help to raise the pin (red circle) of the bottom part a little bit. However, even pressing the microswitch with a pen, for example, requires a relatively large amount of force.
Any suggestions are welcome.

If this is also the problem with your button, I do not know of course.

I have two Fibaro ‘The Button’ devices, but I am unable to add both of them to Homey Pro 2023. I think it’s a bug in the Fibaro app (v.3.7.17) but I’m not sure. That’s why I am wondering if anyone else has the same issue?

The reason why I think it’s a bug in the app, is that Homey is showing 2x the green success-mark when adding the button to Homey (so Homey makes some connection to the Button), but after it says to be patient while the device will be added, I receive the message that it cannot connect and something went wrong while communicating the device. I also have a second Fibaro ‘The Button’ which I had installed to Homey some time ago and which was working fine. So I reinstalled this button but unfortunately this now will also give the same error message. And I tried to install other Fibaro products (like the wall plug) but they can be installed without issues!

So I am currious if anyone else experience the same problem with adding The button to Homey. If so, it is most likely related to the Fibaro app. If not, it might has something to do with my hardware or zwave network.

— restart Fibaro App
— restart HP23
— do the inclusion near to HP23 (normally not necessary, but maybe it’s a better, stronger and more stable Z-Wave signal)
— use new batteries

After restarting HP23 or PTP, wait 10-15 minutes and try to include the Button again.
You can also check Developer Tools → Z-Wave if there are some „unknown“ NodeIDs. If so, please try to delete them first.

Thank you @DirkG for your reply and help.

I tried all your options, including factory reset of the Fibaro The Button (several times), and even a factory reset of Homey (and restore back-up).

I noticed several Unknown Nodes like you described. At first, I was not able to delete them, whatever I tried. But after many, many attempts I was suddenly able to delete all of them! Then I added the first Fibaro The Button and yes, it was finally successful!!

However, I am still not able to add the second Fibaro The Button to Homey as it still gives me the same error message. What I think now is that every time when it fails to include, it creates an Unknown Node (which becomes visible after a restart of Homey) which has to be removed before I give it another attempt.
So I keep trying: Trying to add the device to Homey → reset The Button → restart Homey → Checking for Unknow Nodes → try it again.
Till now, without luck. But I believe that if I keep trying, it must succeed someday… :crossed_fingers:

i think there are problems with cloud service

i got errors on all kind of products and after restarting homeypro 2023 its not connecting to the cloud anymore

cant connect wizard devices cant connect my fibro 2 way device ect so i think we need to wait sometime till its fixed