Fibaro Smart Implant measurement issue

Hi Guys!

I´m struglging with the Fibaro Smarrt Implant module.
I configured the both inputs to be analaog with high sensitivity. For tests I use a simple 9V battery.
When I connect the battery to IN and GND for the first time I get some reading. In most cases it is not correct but this is not critical for future application. I just need to see if there is any voltage applied at all.

Issue: When I disconnect the battery, the value for IN1 remains the same for about a minute. Then it drops to zero. After getting first measurement the sensor seems to get some kind blind. It ignores removal of the signal and it ignores any input in IN2.

Simple “open/close” check works fine. But the voltage measurement seems to be buggy.

Anyone an idea why it works this way?



The manual says you need 12V for analogue 0-10V input.
The analogue input is “open collector” input, which means when no signal is applied, the input it is undefined. So when you add 5V the signal is defined, but when you remove it, it will stay 5V due to capacity. If you expect it to be 0V, you have to shortcut the input. Or you need a pull up, or pull down resistor.

I did short the inputs after it detected external voltage. It should drop to 0V but it doesnt. It remains at the measured value doesnt matter what I do.
When one IN has detected something, the second IN doesnt detect anything no matter what I connect to. The measured value remains there for minutes. Doesnt if shorten or left open or other voltage applied.

I tested it with a pull up and without. Results are similar except when pull up is active it shows 10V for open circuit. When I connect a battery then, the input change to the battery voltage but after disconnection it remains at the mesured voltage for minutes. The update frequency seems to be very low.
Bad connection to Homey is not the problem as the implant module is place about 15 cm away.

In the advanced settings, have you set input 1 and 2 to analogue?
Otherwise reset the implant, while al electrical connections are wired, then pair again.

Thanks for the suggestion.
Did already try it. Tried every single option to wire or set it up. Advanced settings are correct otherwise it would not show any voltage.
The update rate is incredibly low. Doesnt matter how I set the parameters for report time interval or report threshold. It doesnt change anything.

Here my implant is working fine.
I have no more suggestions. Could it be the device is just broken?

In the world of semiconductors everything is possible. I have another one and will try it as well.


Just let me know👍


Tried another implant module Same story, It takes a lot of time to update. When I use it as just contacts it triggers the alarm very fast, maybe 1-2 seconds.
Same story for both modules. Setting time for report interval doesnt change anything.

Have a look in Insights if it really takes so long.