Fibaro flood with shelly 1 relay flow issue

I have made a very simple flow with a fibaro flood sensor and a shelly1 relay. If the flood sensor detects water, the relay should be activated and the attached pump starts working.
In the flow editor I can test it and the pump gets activated. But when I do a real life test the fibaro goes in alarm, but the pump doesn’t start.

The flow is that simple and stupid that I probably overlooked something, but I don’t see it…

Any suggestions?
In the shelly relay I used auto off after 10 minutes. The idea is that if the flood sensor still is in alarm the flow starts again.

The test function in the flow editor is replacing your trigger. In your case the fibaro flood sensor.

So if in the test it works means and because you also dont have a “and” part., you have to look at the trigger side “flood sensor”

If I do the flood test, sensor in water, the sensor goes in alarm (led flash and sound) so the sensor is picking up the water and is giving the alarm. I can also see the alarm in Homey, so I suspect that part is also ok.
But the flow is not activated it seems.

Hmmz, should be easy but sometimes it isnt :grin:

What you can do, is make a notification in the then part. And give iy a logic name “like water alarm”

Easy way to see if its get triggerd.

And ofcourse… you did the famous PTP , wich resolved many problems often, and should always the first thing to do.

I do a PTP every night, but not since I made and tried the flow. I already rebooted the system, without success.
Now trying a PTP.

You a ptp every night? Really or you mean a reset ? Thats something diferent

Homey is connected to a smart plug managed by the hue bridge and every night I do a PTP…
It solves a lot of small issues.
Also now the issue is solved, but I didn’t think about doing a PTP because it’s done every night. So thanks for the suggestions.