Fibaro Dimmer 2 > parameter 38 (firmware version 3.5)

might be a mistake in the manual then and the size should actually be 1 not 2 (like that never happens with fibaro, cough)
try using 38,1,0xFF then

Thanks for your input… the 38,1,0xFF is not possible.

So… would the 38,1,125 be the same as 38,2,255? Strange thing is: at my HCL I really am able to slide to 255 (which is also the default).

Is there a way to see in Homey which value is stored for this parameter? If it really stores 255 I am fine with it… but it is strange that entering 38,1,125 is the “max”.

127 is probably the max you can enter, and no that is not the max, you could try the signed decimal equivalent of 255 38,1,-1

-1 is not even possible to enter.

But could it be the case that in HCL 255 needs to be entered (for parameter 38, with size 2) and in Homey 125 (entered as 38,1,125) which leads to the same? I don’t think so, or am I wrong? Could it be mapped from 38,1,125 > 38,2,255 ?

Still very strange… would be great if there is a solution to get this working… :wink:

that is not possible in anyway, that would be the same as 1+1=5 (which is not the case according my calculator).

better contact athom support then, i gave you all possible ways to give you what you want

Why not?

If I enter -1 I am not able to tap on the approval/OK sign it status grayed out.

1 Like

Hmmm indeed you are correct.

Looks like the expert parameter input has a pretty aggressive pattern for its regex.
It clears out anything not Dec(0-255),Dec(1/2/4),Dec(0-max size)/Hex, without warning here.

I was just wondering if homey was able to transform, I am aware of the hexadecimal values.

By the way 1+1 can be 10 :wink:

I will contact Fibaro thanks for all your input and effort!

not fibaro, athom :scream: fibaro can’t do anything about it.

Sorry, of course. To hasty in my reply. You are completely right :wink:

[Edit later]
Just a moment ago I entered an issue to Athom Support, hopefully they are able to help. I will keep you updated.

Did you receive a reply yet, because I have the same problem. I am trying to set a value to a Fibaro Switch 2. I want to set parameter 57 with a size of 2 but fails.

The data that should be set is: [COMMAND_CLASS_CONFIGURATION] [CONFIGURATION_SET] {“type”:“Buffer”,“data”:[58,2,0,160]} but fails every time.

If I set a parameter with a size of 1 it is always working. Sounds like a bug to me.

EDIT: I think the Atom implementation is not correct for the RAW parameters because it should accept this as well: [58,2,0,30]


No, athom has it right, this is a user error as it is
Parameter ID, size, value
Parameter ID, size, value byte 1 [, value byte 2] [, value byte 3, value byte 4]

Yes, even if the size is 2 or 4, the value will only be 1 decimal value or 1 hexadecimal (which does need 2 bytes in it 0x0000 for size 2)

So it should be 58,2,160 or 58,2,0x00A0

Then they do something else wrong because a size of 2 (value byte 2) does not work.

Try reading my message again :wink:
Size 2 only has 2 hexadecimal bytes (0x0000 = 2 bytes in hexadecimal), each hexadecimal byte contains 2 characters

I meant 2 instead of 4. But this does not work: 58,2,160

Just tested it on my switch 2, and works just fine, you sure you are doing it to the main device, and not the right switch (s2)?
Both parameter 57 and 58, not sure which one you are trying to set, you mention both.

Yes, I did it on the main device please see attachment

(This setting is BTW the same as you see above: “Wattage verzending interval”) but this was more a test to see if this works. I have a problem getting energy usage on the S2 output (this fails somehow).

That is a known issue, athom is actively trying to fix it, just got a mail about a possible fix in the alpha version of the app now.

Is an Alpha build available for download as well, through CLI installation perhaps?