Fibaro Dimmer 2 - Lights don't dim on/off after update to V2


I’m not sure if it is just me, but after updating to V2 ALL of my Fibaro Dimmers now turn the lights on/off without the nice elegant “dim” that used to be done before the update.

Since this gradual diming effect was there from the start, I assume it has something to do with the update. Anyone else having this effect?


No problems here. Four dimmer 2’s softly fading in and out.

Did you report it to athom?

Is this happening when you use the Homey-app to turn on/off the lights? Or the physical switch?

@RoyWissenburg: Nope. At the moment I am assuming it’s a setting somewhere

@Fire69: I have no switches in my house. Everything is fully automatic, so this happens when a flow is started. But I just tested turning on the lights via the app and noticed that when I turn on the lights via the app they dim when the turn on or off

You have no switches connected to the dimmers?

OK, so they turn on/off correctly when doing it manually in the app, but not when it’s a flow?
I’ll test here.

Exactly. When a flow triggers the lights they turn on instantly at 100% without the soft dimming. When I press the button in the app to turn them on then they turn on or off with the soft dimming.

Sorry, I was going to test this and completely forgot about it!

Just did now and I don’t see any difference between flow, app or switch.

Thanks for your effort.

I have noticed something else in the meantime.

I have 4 Fibaro Dimmers set up in my house. 2 are in the kitchen, 1 is in the lower hallway, and 1 is in the upper hallway.

The two in the kitchen and the one in the lower hallway all have this effect. The one in the upper hallways however seems to be acting “normal”…….most of the time. I have noticed that when the flow is triggered it will almost always turn the lights on softly, BUT…when it turns them back off, then the dim effect does not take place.

Right now I am not sure if this is an issue with a) Homey b) the Fibaro App c) my dimmers/switches or d) my flows.

I currently suspect that it actually is a Fibaro App error since I also noticed that my Fibaro Double Switches are not really supported at the moment. The device that is connected to s1 on the switch shows up in the app as it should. Whatever is connected to s2 does not.

I guess I will have to wait for an update!

Yes, fibaro app as of V2 firmware is bugged inside out. I suggest not to wait for update rather to describe and send req email to As soon as they have all the info the sooner fibaro app will he fixed.

Quick check: has this ever been solved? I just joined here and I have a somewhat similar issue. The parameters that should control the fade times are “Time of a dimming step at automatic control” and “Time of a dimming step at manual control”. I tried both, on several different Fibaro dimmers (I have both “Dimmer” and “Dimmer 2” models).

This used to work with other Z-Wave gateways I tested (Fibaro Home Center, Zipato Zipabox and Zipabox2), so it can’t be the dimmers. How do I set these parameters correctly? Or is it proven to be a software bug?

I am unable to help since I have moved on to the Fibaro Home Center. I can only confirm that it was Homey that was causing he problem since this problem was resolved after switching to the Home Center and has never since come back.

See the irony here? I just moved the other way after a complete disaster with HC3.

:smile: Didn’t that just come out? Was thinking of upgrading to that. I guess I should wait a bit.

The features look fantastic and the device itself is incredibly well built. However, the software is a mess. I gave up after two weeks. If they get this under control, it’s probably the most powerful product of its kind.

I can not confirm!
For me, the soft dimming works via parameters 6 and 8. I would be surprised if not? Is a device property and must work independently of the used gateway.

OK, so there’s hope. Can you confirm the exact names of these parameters?

  • Time of a dimming step at automatic control
  • Time of a dimming step at manual control

Which values for a 10 second fade (for example)?

For Dimmer 2

Its a combination of parameter 5 & 6 respectively 7 & 8

Not sure if this is a common problem but I‘m 100% sure that my Fibaro dimmers don‘t accept any changes to these parameters - allthough a message says „changes saved“. There‘s just no change to time changes.

Still struggling with these dimmer settings.

Is anyone here using Homey with Fibaro Dimmer 2 and slow fades programmed using the extended dimmer settings for “dimming step size” and “time of a dimming step”? With Fibaro Home Center 3 and Zipato Zipabox it just worked. Homey = not a chance. This is strange.