Error Panasonic Comfort cloud app

For what it’s worth, my alternative app is now available on Homey Community Store.
Technically, this is the same as installing it from the repo using the SDK, it’s just more convenient if you’re not a developer. (Please do not ask me or this thread about HCS.)


That’s amazing! I’ve got it as an app now but it does not seem to be able to find my panasonic AC. You write that it supports ‘some AC devices’, Do you happen to know which?

No matter what then thanks for doing more than atleast i’m able to! Its been a pain not to have the AC in Homey along with the rest of the devices at home.
Great job!

Did you provide your credentials in the app settings? Do those credentials show device(s) in the smartphone PCC app?
My app should list all devices from all “groups/rooms” configured in the smartphone app.

You’re the first known user beyond myself! :slightly_smiling_face:

Feel free to DM me screenshots, if those look useful. I haven’t yet checked how we can pull logs from HCS apps.

I’ve provided credentials in the settings of the app. I have used my extra ‘homey’-account for that, which is not blocked out due to, to many login attempts.

Coming to the usual screen where you select the devices you want to add it just says “no new devices to be added”.

HCS will publish 1.0.1 of my app this evening: Panasonic requires a newer “appVersion” to be sent with authentication (probably corresponding with the recent notifications in the Android app).

@Mr_Meri’s problem is not yet solved, so your mileage may vary. I welcome feedback from willing testers, though :slight_smile:

Many thanks for your efforts!
I also get you the error: “No new devices have been found” when I try to add my AirCon
Running ver. v1.0.1.
Uses secondary account in relation to PCC which is not “locked”
Thanks again!

I’ve submitted 1.0.2 to HCS, will hopefully be available on Thursday.
The logs (last 1000 lines) are now shown in app settings.
If you want to submit your logs, copy the entire text and send it as DM, or create an issue on Github.

Great job @Robert_Schmidt :+1:t2:
Are you going to try to get it in the Homey App Store?

Personally I’m not a fan of HCS, but maybe for this app I have to install it.

It’s not very likely.
First, they won’t approve apps that do virtually the same thing.
Second, they demand a ridiculous amount of effort into images, description etc. Basically, they are getting the app developers to do marketing for Homey, for free.
If I’m to make a commercial level app for a commercial platform, controlling commercial devices, I want a cut.

You should count the number of Yale apps in the store :wink:

1 Like

Comfort Cloud app recently started to return an error code after failing login: E0011. Panasonic support say it implies “Too many connections”. This is very persistent, and only when the Homey Panasonic Comfort cloud app is, or recently has been, enabled…

There’s a new app from @Robert_Schmidt, see above. There’s one bug regarding the login but I think he’s fixing that.

@Robert_Schmidt, thanks for the alternative app :slight_smile:
I also get “No new devices have been found” (running v1.0.2), and same result even if I specify a random user and password, and no log entries.

Thanks for that feedback! Hmm… something must be different in how HCS packages the app, compared to how the Homey CLI does it for me locally. Very strange - I’ll discuss with the HCS guys.

Edit: Turns out HCS is incompatible with Typescript apps. They’re looking into it.

That’s amazing Robert - great job! Looking forward to see if it works :slight_smile:
Now i just gotta resolve the issue i now encountered that i’m unable to instal apps from the community store all the sudden… Sigh…

HCS had more issues this weekend - I suspect the problem is not on your side.

Edit: HCS is back up, and my app has been tested (without physical device :slightly_smiling_face:) by @Adrian_Rockall (thanks!). I’m not able to verify until after the weekend.

1 Like

HCS is back online, app downloaded and it works like a charm! YOU are amazing! Great work.


@Robert_Schmidt My Panasonic Comfort Cloud Aletrnative app v 1.0.3 stopped working. Any adjustments on my device return “Request failed with status code 401”
Have restarted the app, but same behavior. The Panasonic Android app with the master logon account works normally.

We worked it out in DM. After 1) setting wrong credentials (e.g. temporarily remove the last character from user name), 2) forcing a service request (e.g. change target temperature or start pairing process), and 3) correcting the credentials, the token will be guaranteed to be regenerated. This worked for @MbenzNo.

I’ll make sure the token is regenerated after “Save changes” is clicked, even if creds are unchanged.

Just installed your app. Works perfectly with three units! Thank you very much.

1 Like