Email Sender does not send images anymore


For some reason I cannot send images withe the Email Sender app anymore. Plain text still works. I get the following error:

This started about two weeks ago. I already reinstalled the app, but this did not help.

Works fine here (Pro 19) What Pro do you use?

(and yes, the snapshot appeared in the mailbox)

What if you send that same image per another app, for example:
Screenshot from 2023-03-25 18-51-23
Does that work?

Have you tried to mail other image files?

I use a Homey Pro 2023, but I am pretty sure it already stopped working on my early 2018.
Sending that same image via push works fine (Cool, I did not know that could be done too!).
If I run the flow I can see that the card with the push-message finishes ok (image received on my phone), while the email-card wiggles and ends in error. (Invalid App Event: GetImageBuffer)
As said, sending a non-image email works fine.
I already reinstalled the app.

As an alternative, you can send images with CallMeBot (Signal & FB Messenger) and the new Telegram app.
Not sure how they run on Pro 23

Thanks for the tip
I already use CallMeBot for Whatsapp (no images supported there). It runs fine on 2023. That Telegram app looks very interesting, I might try it!

1 Like

Could it be that this issue is caused by the changed folder structure of HP2023? I found that the same error I receive in Email sender was fixed in CallMeBot.

This is the relevant post: [APP][Pro] WhatsApp, Signal, Telegram, Facebook messenger - #198 by Peter_Kawa

Today it spontaneously started working again.
Since the Email-sender app was not updated, I assume this is related to yesterday`'s Homey firmware update to 10.0.0-rc.90.

1 Like