Dio App

Agreed - but normally fixed pretty swiftly.

Not as much of an issue for me when Devs are doing this in there own time, annoyingly the majority of the ones I’ve had issues with have been AthomBV apps, mainly LightwaveRF, Heatmiser and now DIO.

Agree about monetising the store though, compared to the price of major hardware, if the apps worked as well as the flows and software it would be worth paying for them.

Bridge bought, any links you have on the flashing/setup process would be most appreciated - found a few on google but if you have it working well will be worth following that one.

I’ve had a lot of experience with RF., I use it a lot. The best thing I’ve found is to just not rely on an App to make them function , rather just use a really good universal RF remote learning system that just copies the remotes and plays them back.

It opens up a lot of new possibilities. You can buy any cheap RF gear from anywhere and not have to stress wether there is a compatible app for it…

Over the years I’ve found some fantastic cheap RF gear on AliExpress. Some that actually works better than the expensive main brands.

I never have to worry if they will work. I just record the codes, that’s it…

1 Like

Just thinking is this going to work the other way? For receiving as well as transmission?

Although I have some devices I can use to transmit RF to that I currently can’t I mainly need the device to listen out for the RF as a receiver and send a signal to Homey to trigger a flow…

Will give a brief run down tomorrow.

There is a bit involved if your a first timer to Tasmota flashing…

In the meantime lookup the guides on YouTube., You’ll need to also buy a cheap USB to serial interface to upload the firmware onto the SonOff.

There is also an option for you to just buy a Broadlink Pro instead. It would be easy (no hardware flashing) but with the Tasmota / SonOff combo I’ve found it to be a lot more compatible in reading codes from obscure or proprietary RF devices … (not including rolling codes)…

1 Like

Agreed!
Additionally, if someone happens to have the HCS app installed (pro only), there’s a nice central control panel for update settings

From what I can see this will only allow me to transmit RF and not receive, which still renders my light switches useless :frowning:

Just change “E3C316” in the logic card to what ever RF code you want to listen out for.

1 Like

Change “ rfbridge1” to the MQTT topic name that you create for your SonOff Rf bridge ….(if you end up using one)

1 Like

Cheers Russell, bridge is arriving today so once I’ve flashed it will give this a go.

Cool. Once you flash it with Tasmota also do a secondary flash of the RF chip using a firmware called “Portisch”

It will give it a lot more features and control. Also allows for capturing / sending raw data …

1 Like

Perfect, got Tasmota/Portisch flashed, MQTT setup, MQTT client working on homey, can SSH into my Pi and trigger flows using MQTT test messages from the command line, but can’t see how to get Tasmota to forward any RF signals it receives through MQTT?

Ok seem to have resolved that now, they’re coming through on the RESULT topic, but I’m not getting RF Codes like yours I’m getting strings of letters like so: (this is all one button press)

17:50:19.674 MQT: tele/rfbridge/RESULT = {“Time”:“2021-10-19T17:50:19”,“RfRaw”:{“Data”:“AA B1 04 014A 04D8 00BE 04D8 381828 55”}}
17:50:19.919 MQT: tele/rfbridge/RESULT = {“Time”:“2021-10-19T17:50:19”,“RfRaw”:{“Data”:“AA B1 05 0154 09D8 00A0 04BA 279C 481828382838283838283828283828382838382838282838382828383828382838283828283838283828382828382838283828382838283828382838283828383828 55”}}
17:50:20.404 MQT: tele/rfbridge/RESULT = {“Time”:“2021-10-19T17:50:20”,“RfRaw”:{“Data”:“AA B1 05 015E 09D8 00A0 04C4 279C 481828382838283838283828283828382838382838282838382828383828382838283828283838283828382828382838283828382838283828382838283838282838 55”}}

Heres an example of one I use for transmit… Don’t forget the raw 0 command at the end.

rfraw AA B0 21 03 08 01CC 047E 30F2 28181819090908181819081818181818181818181818190818 55; rfraw 0

rfraw 0 Turns off raw mode and puts the RF bridge back into normal mode after each transmission otherwise it just stays in raw mode.

It needs to be in normal mode for it to be able to interpret the 6 digit Hex identification code of each device when trying to monitor for wildcards …

I’m not sure I’m following, I’m meaning when I use a press a remote button and I set Homey to receive the MQTT based on that code - yours seems to be a short 6 digit Hex Code but I’m getting the above, loads of raw data?

Yep, if you read my last posts your Rf bridge is always stuck in raw mode as your not putting “Raw O” at the end of each MQTT command that you send so the bridge is able to revert back to normal after each RF transmission.

You always want the bridge to be in normal mode while listening out for RF commands.

When transmitting RF code you want it to activate raw mode , send the payload , then close raw mode.

Raw mode is only used for transmitting…

When in normal mode (listening mode) Tasmota receives the RF signal from a device and then decipher’s the unique 6 digit ID code thats mixed into the code thats in the transmission …

You only need to deal with the 6 digit ID code for your wildcards …

I’ve not tried to transmit anything yet, only receive, but while I assume my rfbridge is in normal mode, when I press a button on a RF remote, nothing appears in the console, and nothing is sent by MQTT. Is there a command I need to use to get these RF signals to show/send?

Sorry , I had assumed you were still in raw mode.

Are you sure the test device is working ok ? Try another … You should see info pop up in the console when ever there is RF activity…

Also did the flashing of the RF chip go ok… ?

1 Like

Flashing of the chip worked fine both Tasmota and Portisch, can put it in raw mode using rfraw 177 and see the codes, but when I turn it off I get nothing, tried a few different devices.