Homey Community Forum

Device status not correct

When changing the state of some devices, no real action is done, but the app shows the new wrong state. E.g. turn on lamp, lamp doesn’t turn on, bit the app says it is turned on. This is very annoying as I just cannot trust Homey anymore…

At least give us more info, what devices ect ect

If you want some help with your problem, provide us with as much info you can.

1 Like

It’s a quite general issue. It happens on my Everspring and Fibaro wall plugs. Sometimes it happens, sometimes not, so unpredictable…

as stated before. Which devices are you trying to control? Which app is used. How are you doing these actions? By phone, speech or browser?

Hi, I’m using Everspring wall plugs AN158 and z-wave Fibaro wall plugs. As app the Fibaro and Everspring apps.

Action are done by phone or by flows.

I started a topic in the app-section on an issue like this.

I only use z-wave and homey is dumb as a brick when it comes to z-wave device status.

I have just given up.

cant agree with you. Here I have multiple zwave devices and all seems to work well. So I guess it depends on the situation. Anyway. @Gomfan have you already tried to put the devices closer to homey to see if its an range issue? When you do it by phone are you seeing any error message popping up? Sometimes the network is busy (happend to me some time) and you get an message that the request failed.

Have you already tried to reboot homey or the 433 chip ( can be done using the beta app -> settings )

I have 50 z-wave devices.
Most apps doesn’t handle status updates when the devices are manipulated via direct association.
And, as the original poster wrote it is possible to get stuff out of sync, via the web interface, even when z-wave is a two way protocol.

Thanks Jeroen!
I already rebooted and the range is approx 10m in the same room. I don’t receive an error message… Seems like there is no two-way communication.


I wrote my findings here. Hope it helps.

Same problems here. I’m using Fibaro doorsensor 2 (z-wave) and an Fibaro Wallplug. Home says the light is on but the wallplug doesn’t switch! Very annoying!!

Same problems here. I might switch to Homekit compatible Fibaro door sensors, or replace by Elgato devices. That also gets rid of the inability to update the firmware.

Still the same status problems. If I switch the wallplug in the Homey app it shows the Fibaro wallplug is off while the wallplug is still on (there is a distance problem I think). I am not using associations. The z-wave protocol shout use bi-directional communication but this still doesn’t work. Or is the problem the Homey??? I regret I bought the Homey and Z-wave modules.

1 Like