Connect Flic2 Hub & Buttons to Homey with Flic app

Thought I post the how-to with visuals on connecting my Flic Hub 2 LR with buttons to the Homey Pro. I forgot how it worked and the info/app was not clear at all - so here is a report of the “How I did it” for next time I forget :slight_smile: Hope you find it usefull too.

I AM NOT THE FLIC APP BUILDER, just a user… <

First I have Homey Pro, Flic Hub 2 LR and some buttons:
Have the Flic Hub and buttons up and running.
Add a button to the Flic hub.

  • if you add a Button to the Flic hub give it a simpe name, no spaces.
  • add as actions the HTTP “Internet Request” and save it for now

Install the Flic app on Homey Flic App for Homey | Homey

Add the Flic APP:

Install the Flic APP

See and add your Flic HUB connection (which is a button)

Click - goto the added “device” first menu option (bottom) it shows button actions

Click - goto settings right top corner
Name the button, add it to a zone, change icon etc.
Click - goto advanced settings
Now here you see the webhook addresses generated that we need to copy later into the HTTP internet request setting of the Flic button action later

  • Have the Flic Hub button app open next to your Homey app (to switch easy)
  • Add the exact name where it says “Pending” of the button you setup in Flic
    Save it all

Repeat this step for each action you want to define on the button (click, double…):
-Switch to the Flic Hub app and open the button you named in Homey
-Select the action and copy paste the full webhook line from Homey app settings to the Flic Hub Button “Internet Request” line settings. Make sure you select and copy the FULL webook, standard it selects just a part (if needed copy it first to Notepad to check - the URL should look like this:

https://webhooks.athom.com/webhook/[uniquecode]/?id=[uniquecode]&action=click&flic=1

Set the action to POST and save/close it

Now you can

  • select your defined Flic Button and the action as part of a flow
  • use the button UI in Homey or click the actual button
  • it seems the button history in Homey does not work/show (in my case)

Feel free to update or suggest improvements or other tips.

[END]

1 Like

With Homey pro update v7.2.0 i now get an error when testing the button in Homey. It reports a red alert:

TypeError: Cannot read property ‘trigger’ of undefined

This to me seems like an SDK integration error due to updates? I reinstalled the button and it gave the same error.