Add Flic 2 button to Homey Pro: How to?

I just bought two Flic 2 buttons and wanted to use them to trigger advance flows in Homey Pro.
Spoiler alert: It will not work (I didn’t know that when I set out on this journey.
Should probably delete the entire post :- )

My setup:


Added device
In Homey, added a device…

It found a device…
…but “Flic1”? Is that just a generic number or indicates it that it’s for a “Flic 1” model button? Let’s see…

It got it added and I renamed it to “flic1Music”.
Opened the settings and changed the “ButtonName on Flic App” to the same, “flic1Music”.

Copied the wekhooks for click, dblclick and hold so I can paste them somewhere in the Flic app on the phone, as it says in the Flic app for Homey:

Saved the setting changes. At this point we’re done with step 2. in list above.

On the PHONE!
Opened the Flic app on the phone.

Since I don’t have the Flic hub, I had to choose “Phone” (Getting a bad taste in my mouth… Does this mean that the button requires my phone or the app installed on the phone all the time? Let’s find out…)

Followed the instructions for the pairing process…

I then went on to add an action for the button’s click event:

and went straight for “Advanced”!!! That’s where we’re heading. I hope. Selected “Internet Requests” 'cause I’ve seen others writing that here on the forum

Then I pasted the “Click” webhook I copied in the settings screen for the button in Homey and pasted it under “URL” and selected request method “GET”. Again with the bad taste in my mouth. Prior experience with webhooks tells me that my homey’s ID should be in the link if going over internet - or my LAN address if going locally - this URL’s got a unfamiliar ID in there… well, have to follow the guidance given… Paste:

Didn’t fiddle with anything else as it seemed “Post” related. Ended up looking like this:

Before adding the others, I though I’ll give the “Click” event a go. Clicking the button yielded nothing (of course, I would say). I need a listener for the hook in Homey, but what to listen for? The URL is odd compared to what I’m used to (space inserted intentionally):
https:/ /

This is what we’re taught it should look like:
https:/ /[homey-cloud-id]/my_event?tag=my_tag

I’ll try setting up a listener on the “xxxx” (actually a long hex string).

Saved it and clicked the button once… waited… silence…
It would surprise me if it worked. My logic says that I should put the correct webhook into the button and I should be able to do that in the buttons device setting screen in Homey.

If that would work, that would mean that the button talks directly to Homey over zigbee or something. However, it turns out that my research before I bought the #¤%&/ buttons was waaaaay under par:

BT? BT? Really? Anyone want to buy 2 unused buttons for 30% of the new price?

My motivation is out the window…

There is however a very simple way to get the button to work by using the app on the phone, and instead of selecting “Advanced > Internet Request”, I could have selected “Smart Home > Homey > (select a simple flow)”. Here’s a video that explains all this.

The simple flows was however not part of may use-cases… And the BT thing makes the button 100% dependent of the phone, I think. I hope I’m not right and can anyone tell me:

  1. Is the button dependent on the phone or a Flic hub?
  2. Can I get it to call an advanced flow?

I’m going to bed

Update: I dug the buttons out of the bin and started over the normal rout:

With the normal setup and doing “Smart Home > Homey > (select a simple flow)”, the button is dependent on the phone being present and BT on. When set up like this, it works fine. If you don’t use if for some time (>15min?), I might need an extra click to wake it up maybe? We carry the phone with us constantly, so maybe this isn’t so bad?

(these are the simple flows triggered in Homey when pressed…)

The setup is sooo practicle in the home office:
Click: Play/Pause the office SONOS speaker
2Click: Set volume to 50%
Hold: Set volume to 10%

So, I will continue to to use the buttons with the phone/BT on, but haven’t given up on getting it to talk to Homey directly. Guess that’s where the “Flic app” for Homey comes into play. Can’t see the button communicating with that app. Anyone got some experience with that?

It would still depend on your phone or a hub, as per the app’s blurb: “This app uses Athom Webhooks and Flic’s config on Phone or FlicHub”.

1 Like

I was hoping for something similar to the NFC stickers: Put webhook URLs somewhere in the button and once clicked, it’s received by the “Flic app” on Homey, as it has BT built in…

(BT support: Homey Pro 2023: BLE 5.0, HP’19: BLE 4.0)

…and I could set up regular webhook listeners in an advanced flow.

That’s not how the app works (or BT/BLE, for that matter).

Then I would say Flic 2 is not buttons for Homey Pro. Thanks for your time and knowledge, Robert! Cheers!


I have also Flic2 buttons and I am using the Flic app for starting the flows in homey. Now for 2 days it is not responding to my flows. I see the button be clicked in the Flic app but nothing happens. When I delete the flow and add the flow in the Flic app it works for a bit.

I also have tried Webhooks HTTP in Flic app and have the same problem.

Has someone this problem also or a fix for this?

Not sure if my experience helps, but I have had no problem using Flic buttons and internet request rule in Flic app - post - webhook from Homey. Then I can control anything I want with adding the three click types in my flows.

This week, I received a Flic mini hub. Moved the buttons from phone to hub, readded the webhooks, and all my flows work as before. Now the buttons work when I am not at home (my phone not present).

Ideally one shouldn’t need the Flic Hub, and connect the buttons directly to Homey. That kind of setup should work once all devices have built in support for the Matter protocol. (I ordered my Hub a long time ago on Indiegogo, together with the Flic Twist).

Hi D
I saw you input at that you have issues adding more Flic buttons in Homey Pro 2023. Have you found a solution or a response from support?

I have the same problem. Added 3 buttons but now my Homey can’t find anymore. I had an idea to just set up webhooks ant then call them in the Flic hub but I can’t find how to activate a flow using that method.

This works quite ok.

Example webhook (replace with your ID):

Create a logic trigger that starts a flow:

You can use one webhook, and use tags to send what type of click happened on Flic button.


Yes, I tried webhooks thrue a webhook app in Homey this morning and it worked :sweat_smile:

Thanks for a fast repley.
Have a nice day!

1 Like