Cannot include Aeotec Garage Door Opener

I cannot seem to include the Garage Door opener, either gets stuck at the security key setup, or at a XX/18 command class or just comes back as unknown wave device.

Tried around 30 times, then gave up, even tried excluding between attempts, and had the unit within 30 cm’s of the controller as well.

Its an AU frequency Homey and GD Opener, not sure if that makes a difference ?

I have the AEOTEC plugin installed from the App Store, and all my other Aeotec devices work fine.

Can anyone offer some assistance or ways to get this included ?

If you get it included as unknown Z-wave device, what is the node information (devices > unknown Z-wave device > node information) and in particular the ID’s that is shown for this device?

Likely the AU specific productTypeID is not listed in the Aeotec app for the Aeotec Garage Door Opener… which will result in not recognizing the right driver for your device… hence the Unknown Z-wave device…


I also have AU Homey and AU Garage Door Opener (Gen 5).

My one added as a generic device. But won’t function. I cant use the app to open / close. This worked fine on the Vera Edge and when i manually press the button so the device is fine.

I have attached the config that comes up on Homey. Any help appreciated.

For reference, I have the same controller, and it workes for me.

Should not matter to much, but I run a modified version of v1.6.5 of the app, since the control of the garage door is inverted (reports open when closed and vice versa). Worked before with older version, even though the door status was wrong.

The hole implementation of the Aeotec garage door controller needs rework. It’s not just the issue I mentioned above. The mobile card is not built in a good way, where the button to close/open the door and the representation of the door state is the same button. It should have been done more like @TedTolboom made the IDLock, where one icon just represent the state of the door. And one toggle-button allows you to change that state.

I have reported it here, but I am afraid I am not a competent enough programmer to resolve this my self.

[-1-] The Logic is reveresed for “locked/unlocked” state
The Garage door controller ZW062 seems to have reversed locked/unlocked logic, which @yhaugo. already tried to adress with this pull request. But this request got stuck and never implemented. This is needed.

[-2-] The class and mobile card is not really right for this driver
This is how the device shows up in homey.
The toggle switch is both the button to change the state of the door AND the representation of the tilt-sensor. I think these should be separated, one button to toggle the door to open/close. And one state to show if the door is opened or closed (locked or unlocked, since it is represented as a lock, not a door)

Best of all, would of course be if there where a class for doors, since this is not really a lock, but it’s the closes class there is i guess

@surges thanks for providing the Node ID…
which confirms that indeed the ProductTypeID and Product ID for the AU version are not “supported” (yet) by the Aeotec app… so during inclusion, Homey’s core does not find a app / driver that uses these ID’s…

For some devices the AU region ID’s were added after confirmation of @danone that these worked ok.

Athom is currently re-writing all their Z-wave apps to become SDK2 compatible. I’ll ask the Athom developer to include all the ID’s to support the different regions. But it helps to get the confirmation that it is working ok…

So @surges @Tony_Burn you can help here too… :stuck_out_tongue_winking_eye:

By manually adding the right ID’s to the Aeotec app and confirming that it works.

  1. download the Aeotec app from
  2. Modify (with an text editor) in /app.json the device manifest: on line 486:
"productTypeId": 3,


"productTypeId": [3, 515],
  1. Save the file
  2. Install the Command Line Interface (CLI), as explained in this guide [HOW TO] CLI install method
  3. Install the app via Athom app install
  4. Remove the Aeotec Garage Door Opener from Homey and re-include based on the new app; it should be recognized now
  5. Check and report what is working and what not

@TedTolboom thanks for this info, i’ll try it tomorrow and report back.

Would it be helpful to obtain all the ID’s from Aeotec for AU devices and submit them for inclusion ?

I have a direct line to the AU distributor so should be able to get these.

That would always help… but Aeotec provides certified Z-wave device, so the info should be available on

Like for the Aeotec Garage Door Opener:

Yes, a good number of AU devices IDs have been added into the Aeotec app last year., same as Fibaro.
Those that include as generic devices obviously not. But it is so easy to add the product ID and side load the app into Homey thanks to @TedTolboom clear instructions.

Thanks, I will try this tonight when I get home!

Appreciate the support from everyone!

Hey @Tony_Burn, Who do you use in Aus?

I think we might become best friends on this forum :smiley:

Now don’t forget our first Homey pioneer from down under: @danone


Don’t you think they need their own Aussie section on the forum, just like the other non-english :joy::rofl::joy:


I work with and source all my products from

1 Like

Yep, top notch company! I got Brad into Homey :hugs:

I was about to change from VeraEdge to Plus and Brad mentioned Homey.

So good to deal with. He even logged a ticket on my behalf when I mentioned this issue.

This worked! Thanks Ted.

Garage Controller is officially working

Nice! Keep this trick in mind…
some Z-wave apps are still quite EU-minded… :pensive:

assuming not all are going to be this easy? Saw the Alexa AU question on the other thread.
Support team seem to be receptive to updating apps but the turnaround time would be long.

Australians have unique issues with smart homes

  • plug sizes
  • different power voltage
  • different power plugs
  • Zwave devices availability
  • Different Zwave frequency
  • alexa apps not created for en_au
  • timeout issues on other country servers (ie. smart locks)
  • Different Zwave product Ids
  • Different product driver versions (Tplink)

and the always annoying products not official released here.

You joke about an Australian forum DaneedeKruyff, but I would be really interested in how other Australians over come these issues.

1 Like

@Jamie Good point…

You could create a “Homey going Down Under - Tips & Tricks” topic, or something like that… where you can share you experiences and tips…

Don’t think you qualify as non-English speaking :wink:

1 Like